Results 1 to 8 of 8

Thread: Migrating only domains, users and mailboxes between Zimbra servers

  1. #1
    Join Date
    Mar 2010
    Posts
    17
    Rep Power
    5

    Default Migrating only domains, users and mailboxes between Zimbra servers

    Hi all,

    I actually have my ZCS server running:

    $ zmcontrol -v
    Release 6.0.10_GA_2692.UBUNTU10_64 UBUNTU10_64 FOSS edition.
    $

    We have a clean, new, installed server running latest ZCS v7.1.4.

    Is it possible to migrate just the domains, users and mailboxes from the old server to the new server?

    If this isn't possible due to the different versions, the other option would be to install v6.0.10 on the new server, migrate just the users, domains and mailboxes, and then do the upgrade to v7.1.4.

    The idea is to reinstall the old server after that with v7.1.4 and leave it as an offline backup server.

    Thanks in advanced.

    Regards,
    Joel.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by joelserrano View Post
    Is it possible to migrate just the domains, users and mailboxes from the old server to the new server?
    There are several scripts in the forums that will do that for you. The easiest method is probably following the certified document in the wiki for moving your server from a 32bit to a 64bit server. If you require your original server as a 'backup' (you haven't defined what you mean by that) then it's still available to be upgraded or a new install of ZCS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2010
    Posts
    17
    Rep Power
    5

    Default

    Hi Bill,

    Thanks for your quick response.

    Does it matter that the origin server is v6.0.10 and destination server is v7.1.4? Or as I'm only migrating users, domains and mailboxes the version doesn't matter?

    Regards,
    Joel.

  4. #4
    Join Date
    Mar 2010
    Posts
    17
    Rep Power
    5

    Default

    Quote Originally Posted by joelserrano View Post
    Hi Bill,

    Thanks for your quick response.

    Does it matter that the origin server is v6.0.10 and destination server is v7.1.4? Or as I'm only migrating users, domains and mailboxes the version doesn't matter?

    Regards,
    Joel.
    Forget it, I just saw this warning on the document:

    IMPORTANT: The ZCS release you install on the 64-bit server must be the same release as installed on the 32-bit server. The server can have a different operating system.

    So I need to install v6.0.10 on the new server, move the accounts and data, and then do the upgrade to v7.1.4. Correct?

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by joelserrano View Post
    So I need to install v6.0.10 on the new server, move the accounts and data, and then do the upgrade to v7.1.4. Correct?
    Yes, that correct.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Mar 2010
    Posts
    17
    Rep Power
    5

    Default

    Ok. I'll let you know how it went. Solved :-)

    Regards,
    Joel.

  7. #7
    Join Date
    Mar 2010
    Posts
    17
    Rep Power
    5

    Default

    Hi again,

    On the old server I have zimbra-proxy and zimbra-memcached installed, on the new server I don't. Would this be an issue for the migration?

    Thanks in advanced.

    Regards,
    Joel.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by joelserrano View Post
    On the old server I have zimbra-proxy and zimbra-memcached installed, on the new server I don't. Would this be an issue for the migration?
    If this is a single server then you should not have memcahced nor imapproxy installed, I'd suggest you remove them both (and reset the ports to their defaults). Search the forums for details, there are threads that give you the correct commands for disabling the services and stopping them from being installed during upgrades and resetting the ports. Do that on your current server and restart Zimbra to make sure it's all OK(take a backup before making any changes).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 39
    Last Post: 09-05-2012, 12:18 AM
  2. Migrating users to Commercial Zimbra ...
    By gareth in forum Administrators
    Replies: 0
    Last Post: 07-05-2011, 10:30 AM
  3. Please help with zimbra mailboxes migration
    By gnoma in forum Administrators
    Replies: 0
    Last Post: 06-27-2011, 06:39 PM
  4. From POP3 and 100 scattered mailboxes to Zimbra
    By spiderman in forum Administrators
    Replies: 5
    Last Post: 08-11-2006, 09:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •