Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: CPU High Spikes around every 2 minutes ZSC 7.1.4

  1. #11
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    8

    Default

    Great idea.

    1957 zimbra 20 0 974m 65m 11m S 91.1 4.2 0:02.74 /opt/zimbra/java/bin/java -XX:ErrorFile=/opt/zimbra/log -client -Xmx256m -Dzimbra.home=/opt/zimbra -Djava.library.path=/opt/zimbra/lib -Djava.ext.dirs=/opt/zimbra/java/jre/lib/e ....
    3548 zimbra 20 0 36396 7096 2100 R 2.7 0.4 0:00.08 /usr/bin/perl /opt/zimbra/bin/ldapHelper.pl true KIPgdjmOn ldap_db_cachesize 10000

    Does this mean anything to anyone?
    Last edited by mrcoffee11; 06-19-2012 at 12:39 PM.

  2. #12
    Join Date
    Nov 2009
    Posts
    7
    Rep Power
    6

    Default

    Hello sir! I can't really say what your processes/logs above mean, but one last suggestion (if I may). I typically run the following commands on each upgrade to maintain minimal cpu spikes/usage:

    {most of these I believe you've already done. I'm just stating the "exact" steps that work for me}

    su - zimbra
    zmlocalconfig -e zmmtaconfig_interval=6000
    zmprov mcf zimbraLogRawLifetime 7d
    zmprov mcf zimbraLogSummaryLifetime 30d
    /opt/zimbra/libexec/zmlogprocess

    su - zimbra
    crontab -e
    */60 * * * * /opt/zimbra/libexec/zmstatuslog

    I stopped the logging process:

    $ su - zimbra
    $ zmprov ms fill_in_your_hostname -zimbraServiceEnabled logger


    Then as the root user I edit /etc/logrotate.d/zimbra and comment out all logger related start / reload commands e.g.

    # su - zimbra -c "/opt/zimbra/bin/zmswatchctl restart" > /dev/null 2>&1 || true
    # su - zimbra -c "/opt/zimbra/bin/zmlogswatchctl start"

    Not sure if this was of any help, but best of luck in your search for a solution! :-)
    Last edited by diallo0024; 06-20-2012 at 07:33 AM.
    Ubuntu8 x64 - Zimbra 7.1.4 Open Source version - ESX 5.0

  3. #13
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    8

    Default

    Thnx for your reply. This is what I did in versions before 7.1.4 with success. From 7.1.4 this does not work (for me). Fresh install. Got no clue. Help is very much apppreciated.
    Roderick
    FC11 x64 / Centos 6.2 - Zimbra 7.2.0 Open Source version - ESX 5.0

  4. #14
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    8

    Default

    I got it to stop!

    # su - zimbra
    # zmconfigdctl stop
    # zmlocalconfig -x | grep zmmtaconfig
    # zmmtaconfig_enable_config_restarts = true
    zmmtaconfig_interval = 6000
    zmmtaconfig_listen_port = 7171
    zmmtaconfig_log_level = 3
    zmmtaconfig_watchdog = FALSE

    The question is: is it a problem to to stop zmconfigd? What does it do?
    FC11 x64 / Centos 6.2 - Zimbra 7.2.0 Open Source version - ESX 5.0

  5. #15
    Join Date
    Jun 2011
    Location
    Caracas Venezuela
    Posts
    476
    Rep Power
    4

    Default

    The question is: is it a problem to to stop zmconfigd? What does it do?
    Take a look Zmconfigd - Zimbra :: Wiki

    ccelis

  6. #16
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    8

    Default

    Ok, Zmconfigd takes care of activating configuration changes.
    The zmmtaconfig_interval is normally set to 60 seconds. I changed it to 6000. Still I get these 140 seconds interval high cpu peaks of this process. Could anyone expand on this? Is this a bug?
    FC11 x64 / Centos 6.2 - Zimbra 7.2.0 Open Source version - ESX 5.0

  7. #17
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    8

    Default

    Fedora 11 is depricated so I did an installationl and migration to Centos 6.2 (very very minimal install): performance is really excellent! (and I don't need the zmconfigdctl stop command)
    FC11 x64 / Centos 6.2 - Zimbra 7.2.0 Open Source version - ESX 5.0

  8. #18
    Join Date
    Jul 2011
    Posts
    10
    Rep Power
    4

    Default

    Quote Originally Posted by mrcoffee11 View Post
    I got it to stop!

    # su - zimbra
    # zmconfigdctl stop
    # zmlocalconfig -x | grep zmmtaconfig
    # zmmtaconfig_enable_config_restarts = true
    zmmtaconfig_interval = 6000
    zmmtaconfig_listen_port = 7171
    zmmtaconfig_log_level = 3
    zmmtaconfig_watchdog = FALSE

    The question is: is it a problem to to stop zmconfigd? What does it do?
    Hi ,

    we have the same problem with RedHat 5.7 and Zimbra 7.2 -> high CPU Peaks
    I saw that the CPU Load increase if someone do an upload of an attachment of 10MB..(that is not really much)

    Did this settings help?

    Kind Regards,
    toppse

Similar Threads

  1. High cpu usage on 7.1.4
    By maxxer in forum Administrators
    Replies: 2
    Last Post: 02-03-2012, 06:03 AM
  2. High CPU usage on server and client
    By jack-Z in forum Administrators
    Replies: 10
    Last Post: 01-07-2009, 10:12 PM
  3. Zmlogger and CPU Spikes
    By andreychek in forum Administrators
    Replies: 4
    Last Post: 11-01-2006, 08:01 PM
  4. HIGH CPU use
    By brwatters in forum Administrators
    Replies: 3
    Last Post: 07-05-2006, 09:47 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •