Results 1 to 3 of 3

Thread: Trying to install Globalsign SSL certificate

Hybrid View

  1. #1
    Join Date
    Dec 2011
    Posts
    7
    Rep Power
    4

    Unhappy Trying to install Globalsign SSL certificate

    I'm trying to install a commercial certificate for hours now, but I just cannot get it to work (on Zimbra Server 7.1 OS version).

    A week ago I have ordered a GlobalSign Domain validated certificate. I successfully installed the certificate on my webserver. However now I'm trying to install it on Zimbra Server, but as stated without luck.

    I tried to install the certificate using the admin interface:

    - First I created the CSR
    - Next I choose the three .cer files provided by GlobalSign
    - After clicking 'Finish' I get the following error:

    system failure: XXXXX Error: Unmatching certificate (/opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp/current.crt) and private key (/opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp/current_comm.key) pair.
    I also tried another approach (using the commandline) without any luck:

    Code:
    ./zmcertmgr deploycrt comm /ssl/www_domain_com.key /ssl/ca_bundle.crt
    But that resulted in a similar error:

    ** Verifying /ssl/www_domain_com.key against /opt/zimbra/ssl/zimbra/commercial/commercial.key
    unable to load certificate
    140117204260496:error:0906D06C:PEM routines:PEM_read_bio:no start lineem_lib.c:696:Expecting: TRUSTED CERTIFICATE
    XXXXX ERROR: Unmatching certificate (/ssl/www_domain_com.key) and private key (/opt/zimbra/ssl/zimbra/commercial/commercial.key) pair.
    XXXXX ERROR: provided cert isn't valid.
    I don't have any more ideas as to how to get it working .

    P.S. If it matters I still have the 'original' CSR en .key file which I used to request the certificate at GlobalSign.

    Any help is much appreciated.

  2. #2
    Join Date
    Dec 2011
    Posts
    7
    Rep Power
    4

    Default

    Nobody is able to help me with this issue?

  3. #3
    Join Date
    Sep 2010
    Location
    YYJ
    Posts
    1
    Rep Power
    5

    Default

    I'm not sure if this will help - but I was having a *very* similar problem and this page helped a lot:

    Zimbra | dave-smith.co.uk

    The verifycert command failed and when I opened my commercial.crt file, it had a line with both -----end----------begin----- on the same line!

    I added a newline in the correct place and the verifycrt worked fine. I then deployed the cert and restarted mailboxd.

    After that - it worked great! Hope it helps!

Similar Threads

  1. Replies: 1
    Last Post: 04-16-2013, 10:07 AM
  2. Replies: 5
    Last Post: 04-17-2011, 02:07 PM
  3. How to install an existing Wildcard SSL certificate?
    By Mindaugas in forum Administrators
    Replies: 1
    Last Post: 11-18-2010, 06:58 AM
  4. Install a commercial SSL certificate ??
    By nick20 in forum Installation
    Replies: 6
    Last Post: 06-23-2010, 04:08 AM
  5. Replies: 0
    Last Post: 01-15-2008, 01:33 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •