Results 1 to 5 of 5

Thread: Cannot send new messages

  1. #1
    Join Date
    Oct 2005
    Posts
    16
    Rep Power
    10

    Default Cannot send new messages

    Hi there!

    Everything was working fine on my zimbra box until today where I am receiving messages like this one when I am sending a new email:
    msg - system failure: indexMessage caught IOException
    com.zimbra.cs.service.ServiceException: system failure: indexMessage caught IOException
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:174)
    at com.zimbra.cs.index.Indexer.indexMessage(Indexer.j ava:161)
    at com.zimbra.cs.mailbox.Message.reindex(Message.java :421)


    I had a look in the logs and zimbra is complaining that the directory /opt/zimbra/index/0/2/index/0/ already exists.

    Can I safely erase this directory? It is not empty (far from it).

    Any help anyone?

    Thanks,

    Patrick

  2. #2
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default Debian, right?

    I assume you're running on Debian. You've got a permissions issue. Search the forums about the zmfixperms script.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Oct 2005
    Posts
    16
    Rep Power
    10

    Default thanks,

    I am indeed running Debian.
    I fixed my problem, not by using the zmfixpermissions script but by resetting serveral times the correct ownership to redo.log and /opt/zimbra/index

    I have the feeling that if an error occur in Zimbra, those files have their ownership changed to root.

    anyway, thanks!

    Patrick

  4. #4
    Join Date
    Oct 2005
    Posts
    16
    Rep Power
    10

    Default by the way

    by the way, I realisze this is not a specific zimbra question but a more general cyrus question, I was wondering the purpose of /opt/zimbra/index (as opposed as /opt/zimbra/store) and if in case of problem it was safe to erase it.

    Any pointers to a relevant documentation?

    Thanks.

    Patrick

  5. #5
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default /opt/zimbra/index

    That's the Lucene index. It's not a good idea to delete it, no.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Can't send or receive messages
    By hanysys in forum Administrators
    Replies: 10
    Last Post: 05-01-2007, 08:46 AM
  2. New messages not showing up in outlook
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 01-16-2007, 08:17 AM
  3. Spam assassain not traiing properly!
    By Mike T in forum Administrators
    Replies: 1
    Last Post: 10-09-2006, 02:34 PM
  4. Can't send or receive messages
    By kcolgan in forum Installation
    Replies: 1
    Last Post: 09-26-2006, 02:14 AM
  5. Can't send messages through Web Interface
    By rvanscherpe in forum Installation
    Replies: 4
    Last Post: 08-03-2006, 11:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •