Results 1 to 5 of 5

Thread: Zimbra don't recive mail sent from php mail function

  1. #1
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default Zimbra don't recive mail sent from php mail function

    I am trying to configure my zimbra server but it don't recive mail from a php mail funciton..

    i tried to send a mail for the php function to my gmail account and it work perce
    this the header

    Delivered-To: ***@gmail.com
    Received: by 10.42.75.10 with SMTP id y10cs54366icj;
    Wed, 8 Feb 2012 03:48:10 -0800 (PST)
    Received: by 10.14.29.7 with SMTP id h7mr4869178eea.107.1328701689442;
    Wed, 08 Feb 2012 03:48:09 -0800 (PST)
    Return-Path: <anonymous@www.infosys96.com>
    Received: from www.infosys96.com (static.228.93.4.46.clients.your-server.de. [46.4.93.228])
    by mx.google.com with ESMTPS id d47si818388eec.134.2012.02.08.03.48.08
    (version=TLSv1/SSLv3 cipher=OTHER);
    Wed, 08 Feb 2012 03:48:09 -0800 (PST)
    Received-SPF: neutral (google.com: 46.4.93.228 is neither permitted nor denied by best guess record for domain of anonymous@www.infosys96.com) client-ip=46.4.93.228;
    Authentication-Results: mx.google.com; spf=neutral (google.com: 46.4.93.228 is neither permitted nor denied by best guess record for domain of anonymous@www.infosys96.com) smtp.mail=anonymous@www.infosys96.com
    Received: (qmail 30293 invoked by uid 10001); 8 Feb 2012 12:48:18 +0100
    Date: 8 Feb 2012 12:48:18 +0100
    Message-ID: <20120208114818.30290.qmail@www.infosys96.com>
    To: starsool@gmail.com
    Subject: the subject
    From: webmaster@example.com
    Reply-To: webmaster@example.com
    X-Mailer: PHP/5.3.3-7+squeeze3

  2. #2
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default

    update

    i am using this code to send mail, on gmail work and you can see the header on here but on zimbra nothing happen, i can't see mail in the queue on the administration area of the mail server :S

    PHP Code:
    <?php
    $to 
    "*******";
    $subject "My email test.";
    $message "Hello, how are you?";

    $headers "From: myplace@here.com\r\n";
    $headers .= "Reply-To: myplace2@here.com\r\n";
    $headers .= "Return-Path: myplace@here.com\r\n";


    if ( 
    mail($to,$subject,$message,$headers) ) {
       echo 
    "The email has been sent!";
       } else {
       echo 
    "The email has failed!";
       }

    Code:
    Delivered-To: ***@gmail.com
    Received: by 10.42.75.10 with SMTP id y10cs56291icj;
            Wed, 8 Feb 2012 04:45:58 -0800 (PST)
    Received: by 10.14.137.204 with SMTP id y52mr8606352eei.60.1328705157352;
            Wed, 08 Feb 2012 04:45:57 -0800 (PST)
    Return-Path: <info@infosys96.com>
    Received: from www.infosys96.com (static.228.93.4.46.clients.your-server.de. [46.4.93.228])
            by mx.google.com with ESMTPS id t2si946221eef.51.2012.02.08.04.45.56
            (version=TLSv1/SSLv3 cipher=OTHER);
            Wed, 08 Feb 2012 04:45:57 -0800 (PST)
    Received-SPF: neutral (google.com: 46.4.93.228 is neither permitted nor denied by best guess record for domain of info@infosys96.com) client-ip=46.4.93.228;
    Authentication-Results: mx.google.com; spf=neutral (google.com: 46.4.93.228 is neither permitted nor denied by best guess record for domain of info@infosys96.com) smtp.mail=info@infosys96.com
    Received: (qmail 31201 invoked by uid 10001); 8 Feb 2012 13:46:05 +0100
    Date: 8 Feb 2012 13:46:05 +0100
    Message-ID: <20120208124605.31199.qmail@www.infosys96.com>
    To: starsool@gmail.com
    Subject: My email test.
    From: myplace@here.com
    Reply-To: myplace2@here.com

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by s7ar View Post
    i am using this code to send mail, on gmail work and you can see the header on here but on zimbra nothing happen,
    Have you actually looked in the log files for an errors?

    Quote Originally Posted by s7ar View Post
    i can't see mail in the queue on the administration area of the mail server
    You should be using port 587 as the submission port (that will require authentication), are you doing that?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default

    The mail is sent from an other server and it work, also zimbra recive mail from other web mail reject only mail from php mail() function

  5. #5
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    How did you solved this problem?
    How can I authenticate php mail against zimbra?
    Tibby

Similar Threads

  1. Replies: 12
    Last Post: 03-23-2011, 10:39 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  4. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  5. fatal: Queue report unavailable - mail system is down
    By zzzzsg in forum Administrators
    Replies: 16
    Last Post: 08-24-2006, 03:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •