Results 1 to 3 of 3

Thread: zmprov incredibly slow

  1. #1
    Join Date
    Dec 2008
    Location
    vienna/austria
    Posts
    59
    Rep Power
    6

    Default zmprov incredibly slow

    I want to disable all users OutOfOffice-replies but backup their original settings.

    So what I do for each user:
    I run "zmprov ga" to query their actual state and then I run "zmprov ma" to disable OOO.

    Code:
    zmprov -l gaa | sort | while read i; do echo -n "$i:"; zmprov ga "$i" | grep zimbraPrefOutOfOfficeReplyEnabled || echo; zmprov ma "$i" zimbraPref
    OutOfOfficeReplyEnabled FALSE; done
    I've 207 users on my system and the above code takes approx. 30minutes. WOW !!! This is really really slow.

    Any way to make things faster? To query directly from ldap or mysql? Why is it so slow?

    Thnx for your ideas,
    p
    Release 7.1.3_GA_3346.UBUNTU10_64 UBUNTU10_64 FOSS edition

  2. #2
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    It's so slow because every time you execute zmprov, it loads a java application that preforms the changes.

    The only way to make it faster would be to create a script that connects to the SOAP API to connect to the server directly and loop through all of the users that way.
    01 Networks, LLC / Cybernetik.net
    Zimbra NE and OSS Cloud Hosting
    Shared Web Hosting
    Consulting Services

  3. #3
    Join Date
    Dec 2008
    Location
    vienna/austria
    Posts
    59
    Rep Power
    6

    Default

    Thnx for your answer. It makes sense what you say, but I dont have any clue how to achieve what you suggest without writing my own libraries.

    I was looking for perl-modules to achieve what I want, but there is no documented perl-module (despite Login and manipulate Zimbra account with Perl - Zimbra :: Wiki which is for working with calendars).

    There are undocumented perlmodules and example-scripts at SourceForge.net Repository - [zimbra] Index of /trunk/ZimbraServer/src/perl/soap but despite a few hours effort I couldnt get any of them to work. I'm afraid they are all very out-of-date and are not compatible with current SOAP-API.

    This is unfortunate and I wonder how different admins deal with such problems than mine. I guess that scripting with zimbra is important to other people too.

    thnx,
    peter
    Release 7.1.3_GA_3346.UBUNTU10_64 UBUNTU10_64 FOSS edition

Similar Threads

  1. Unable to script zmprov changes completely
    By todd_dsm in forum Installation
    Replies: 1
    Last Post: 12-16-2009, 07:39 AM
  2. Slow CLI scripts
    By CrypTom in forum Administrators
    Replies: 4
    Last Post: 10-27-2009, 07:16 AM
  3. zmprov ca command returns NO_SUCH_DOMAIN
    By admin1 in forum Migration
    Replies: 2
    Last Post: 10-03-2007, 11:32 AM
  4. Replies: 9
    Last Post: 04-14-2007, 09:31 AM
  5. EVERYTHING works, except for zmprov!!
    By GadgetGuru in forum Installation
    Replies: 3
    Last Post: 09-21-2006, 05:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •