Results 1 to 3 of 3

Thread: cli version of "Assign default domain administrator views and rights"

  1. #1
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default cli version of "Assign default domain administrator views and rights"

    What is the cli command that will give the same rights as what happens when i click on "Assign default domain administrator views and rights" under Edit User? I am trying to script things out.

    Also, while i have your attention, when the domain admin clicks to view the email of a user, it sends him to blah.com:7070 versus https://blah.com like it would with a normal full admin. Any idea where its getting that port and non ssl url from?

    Thanks!
    Last edited by MACscr; 02-16-2012 at 12:06 AM.

  2. #2
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    Quote Originally Posted by MACscr View Post
    What is the cli command that will give the same rights as what happens when i click on "Assign default domain administrator views and rights" under Edit User? I am trying to script things out.

    Also, while i have your attention, when the domain admin clicks to view the email of a user, it sends him to blah.com:7070 versus https://blah.com like it would with a normal full admin. Any idea where its getting that port and non ssl url from?

    Thanks!
    So i think the following fixed the url issue, but still not finding a solution for setting the needed domain admin permissions that would replicate the above settings.

    $ zmprov md 'domain' zimbraPublicServiceProtocol https
    $ zmprov md 'domain' zimbraPublicServicePort 443

  3. #3
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    Quote Originally Posted by MACscr View Post
    So i think the following fixed the url issue, but still not finding a solution for setting the needed domain admin permissions that would replicate the above settings.

    $ zmprov md 'domain' zimbraPublicServiceProtocol https
    $ zmprov md 'domain' zimbraPublicServicePort 443
    Nevermind, that didnt work. Still goes to 7070 for some odd reason and non https when trying to use "View Mail" as a domain admin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •