Results 1 to 2 of 2

Thread: A network service error has occured

  1. #1
    Join Date
    Feb 2012
    Posts
    2
    Rep Power
    3

    Default A network service error has occured

    on CentOS 5.2
    Zimbra 6.0
    I run into this error
    after I try to fix "Could not send message due to invalid address(es)"
    So first I use this:

    [zimbra@mail.server.net]$ zmprov ms mail.server.net zimbraMtaAuthHost mail.server.net

    [zimbra@mail.server.net]$ postconf mynetworks

    mynetworks = 127.0.0.0/8 192.168.2.100/32

    so I rewrite (100 is the mail server)

    [zimbra@mail.server.net]$ zmprov modifyServer mail.server.net zimbraMtaMyNetworks " 127.0.0.0/8 192.168.2.100/24"

    stop and start server

    after this the error has change to:
    "A network service error has occured "(change back the settings, no luck error remains)

    So I reinstall the certificate

    Begin by generating a new Certificate Authority (CA).

    /opt/zimbra/bin/zmcertmgr createca -new

    Then I generate a certificate signed by the CA that expires in 365 days.

    /opt/zimbra/bin/zmcertmgr createcrt -new -days 365

    Next I deployed the certificate.

    /opt/zimbra/bin/zmcertmgr deploycrt self

    Next I deployed the CA.

    /opt/zimbra/bin/zmcertmgr deployca

    And I verify the certificate to be deployed to all the services.

    /opt/zimbra/bin/zmcertmgr viewdeployedcrt

    restart server no success
    At start I was able to send mails from outlook and receive them.
    Now is not working anymore.
    So from a webmail problem now is transformed in an entire server problem.

    Error: A network service error has occured
    method: SendMsgRequest
    code: service.FAILURE
    detail: soap:Receiver

    because I'm a beginer in zimbra configuration I only can guess what is the problem , I try all the solutions from the forum... Please direct me. Thank you

  2. #2
    Join Date
    Feb 2012
    Posts
    2
    Rep Power
    3

    Default solved

    in the end it was solved by change back
    mynetworks = 127.0.0.0/8 192.168.2.100/32
    why the error maybe somebody knows

    "Could not send message due to invalid address(es)"
    was fix after the SSH authentication was changed to use password
    (previously I try to configure the server for remote using NX Client and one of the settings was "In the /etc/ssh/sshd_config file, you should have this line if you have disabled password authentication: PasswordAuthentication no ")

    Hope will help for new zimbra users.
    Thank you

Similar Threads

  1. Replies: 2
    Last Post: 11-15-2011, 12:03 PM
  2. A network service error has occurred
    By snake_eyes in forum Installation
    Replies: 4
    Last Post: 06-17-2011, 04:39 AM
  3. Network service error after clicking send from web client
    By mrupright in forum Administrators
    Replies: 3
    Last Post: 04-05-2009, 02:38 AM
  4. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  5. Network Service Error with MIME encoded message
    By Glenham in forum Administrators
    Replies: 2
    Last Post: 10-17-2006, 10:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •