on CentOS 5.2
Zimbra 6.0
I run into this error
after I try to fix "Could not send message due to invalid address(es)"
So first I use this:

[zimbra@mail.server.net]$ zmprov ms mail.server.net zimbraMtaAuthHost mail.server.net

[zimbra@mail.server.net]$ postconf mynetworks

mynetworks = 127.0.0.0/8 192.168.2.100/32

so I rewrite (100 is the mail server)

[zimbra@mail.server.net]$ zmprov modifyServer mail.server.net zimbraMtaMyNetworks " 127.0.0.0/8 192.168.2.100/24"

stop and start server

after this the error has change to:
"A network service error has occured "(change back the settings, no luck error remains)

So I reinstall the certificate

Begin by generating a new Certificate Authority (CA).

/opt/zimbra/bin/zmcertmgr createca -new

Then I generate a certificate signed by the CA that expires in 365 days.

/opt/zimbra/bin/zmcertmgr createcrt -new -days 365

Next I deployed the certificate.

/opt/zimbra/bin/zmcertmgr deploycrt self

Next I deployed the CA.

/opt/zimbra/bin/zmcertmgr deployca

And I verify the certificate to be deployed to all the services.

/opt/zimbra/bin/zmcertmgr viewdeployedcrt

restart server no success
At start I was able to send mails from outlook and receive them.
Now is not working anymore.
So from a webmail problem now is transformed in an entire server problem.

Error: A network service error has occured
method: SendMsgRequest
code: service.FAILURE
detail: soap:Receiver

because I'm a beginer in zimbra configuration I only can guess what is the problem , I try all the solutions from the forum... Please direct me. Thank you