Results 1 to 2 of 2

Thread: [SOLVED]Bad File Descriptor in amavis under Zimbra

  1. #1
    Join Date
    Sep 2006
    Virginia, USA
    Rep Power

    Default [SOLVED]Bad File Descriptor in amavis under Zimbra

    I just wanted to update everyone on the problems I was having earlier(' r') with a bad file descriptor error whenever amavis checks an incoming mail message.

    The cause wound up being with perl. I had a long-ago set variable in my /etc/profile, PERLIO=stdio. This was causing the problem. Unsetting this variable allowed amavis to work without errors. In addition, Mark Martinec, one of the amavis developers, has filed a bug against perl for a similar problem.

    I hope this helps someone out along the line.


  2. #2
    Join Date
    Aug 2005
    Rep Power

    Default Thank you!

    Thank you very much for pursuing this to a successful conclusion and coming back to the forums to share the solution!
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Replies: 12
    Last Post: 02-25-2008, 06:28 PM
  2. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 08:21 AM
  3. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts