Results 1 to 4 of 4

Thread: LDAP settings are being reverted back

Threaded View

  1. #1
    Join Date
    Feb 2012
    Rep Power

    Unhappy [SOLVED] LDAP settings are being reverted back: zmldapreplicatool -t off

    I'm experiencing a strange behaviour when saving user preferences like mail filters. Actually we run a 4 zimbra servers (7.1.3_GA_3346.UBUNTU10_64 UBUNTU10_64 FOSS editio) in an LDAP environment. One is LDAP master the other three LDAP slaves.

    When an user saves it's settings, expecially mail filters on one of the servers (where it's account resides) I can see slapd commits on the LDAP master server like this:

    Feb 23 09:19:21 norther slapd[1616]: slap_queue_csn: queing 0x7f8a4e2c6170 20120223081921.152776Z#000000#000#000000
    Feb 23 09:19:21 norther slapd[1616]: slap_queue_csn: queing 0x964c668 20120223081921.152776Z#000000#000#000000

    which seems OK. Settings are saved. Some time later all settings are lost. It seems like the master LDAP server would revert back all settings we set before. I think the problem has to do with LDAP. Is there anyway for resyncing all LDAP databases between master and slave? Probably in some way the master thinks that settings are old and reverts back previous settings.

    I also started fix permissions on all servers thinking that maybe some data could not be saved inside the LDAP DB but didn't solve.

    I also get an error like this: lapd[1616]: connection_read(43): no connection! but this has been since we've started using Zimbra and anything worked fine before one month ago.

    I want to add that I've updated self signed certificate on the master server some time ago, maybe it's part of the problem.

    Thanks for infos.
    Last edited by eim; 02-23-2012 at 11:30 AM.

Similar Threads

  1. Failed to bind to LDAP server
    By tezarin in forum Administrators
    Replies: 4
    Last Post: 01-23-2012, 08:26 AM
  2. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 02:08 AM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  5. External LDAP settings not saved
    By atpoirie in forum Installation
    Replies: 5
    Last Post: 09-21-2006, 08:55 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts