Results 1 to 3 of 3

Thread: Relay access denied

  1. #1
    Join Date
    Jun 2008
    Posts
    3
    Rep Power
    7

    Default [SOLVED] Relay access denied

    I am having an issue with sending emails in my setup.

    My server is setup, and everything works fine. All users can send and receive emails. However, I have another server that tries to relay messages through our zimbra server. Any messages that are sent by that other server to an external email address give the following message in

    Mar 6 11:11:31 zimbra postfix/smtpd[10268]: connect from mx2.mydomain.com[xxx.xxx.xxx.xxx]
    Mar 6 11:11:31 zimbra postfix/smtpd[10268]: NOQUEUE: reject: RCPT from mx2.mydomain.com[xxx.xxx.xxx.xxx]: 554 5.7.1 <me@external_email.com>: Relay access denied; from=<local_server@internal_fake_domain.com> to=<me@external_email.com> proto=ESMTP helo=<mx2.mydomain.com>
    Mar 6 11:11:31 zimbra postfix/smtpd[10268]: disconnect from mx2.mydomain.com[xxx.xxx.xxx.xxx]

    I have added the IP address to zimbraMtaMyNetworks, but that does not seem to make a difference.

    I am sure that I am missing something obvious, but I can't figure it out. Any help will be greatly appreciated.

    Thank you.
    Last edited by neepie; 03-06-2012 at 12:58 PM. Reason: Marking as solved

  2. #2
    Join Date
    Jun 2008
    Posts
    3
    Rep Power
    7

    Default

    OK, an update.

    I just went through all the steps described at ZimbraMtaMyNetworks - Zimbra :: Wiki and I found that the zimbra settings do not seem to be the same as the postfix settings:

    Code:
    $ zmprov getServer `zmhostname` | grep zimbraMtaMyNetworks
    zimbraMtaMyNetworks: 127.0.0.0/8 10.0.0.0/24 192.168.10.0/24 xxx.xxx.xxx.xxx/32
    $ postconf mynetworks
    mynetworks = 127.0.0.0/8 10.0.0.0/24 192.168.10.0/24
    I have done a postfix reload but that does not change anything. I also tried setting zimbraMtaMyNetworks again through the command line, again no luck.

    How do I get "postfix" to see this updated "zimbra" variable?

  3. #3
    Join Date
    Jun 2008
    Posts
    3
    Rep Power
    7

    Default

    I have solved the issue.

    Apparently I needed to restart zimbra to get the new settings in.

    Would be nice if the setting would have automatically been populated into postfix, but it works now

Similar Threads

  1. [SOLVED] Relay access denied
    By get2guy in forum Administrators
    Replies: 8
    Last Post: 10-29-2010, 09:40 AM
  2. Relay Access Denied, Help!
    By jpcaldwell in forum Administrators
    Replies: 5
    Last Post: 08-15-2008, 09:11 AM
  3. Relay Access Denied
    By AutootuA in forum Administrators
    Replies: 34
    Last Post: 02-07-2008, 08:26 AM
  4. Backup issues
    By telescop in forum Administrators
    Replies: 3
    Last Post: 03-01-2007, 05:09 PM
  5. Move server to different OS
    By EriSan500 in forum Administrators
    Replies: 7
    Last Post: 03-05-2006, 12:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •