Results 1 to 3 of 3

Thread: services ldap and logger failed to start

  1. #1
    Join Date
    Mar 2012
    Posts
    2
    Rep Power
    3

    Default SOLVED - services ldap and logger failed to start

    Hi,

    I have installed in a 32-bit Debian5 server Zimbra 7.1.4 OS edition in production.

    During some integration tests I'ved changed the ldap_starttls_required from true to false and back to true again.

    Since then, I can't startup Zimbra.

    I'm facing the errors:

    Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.

    Starting logger....Failed.
    Starting logswatch...ERROR: service.FAILURE (system failure:unable to lookup server by name: SERVERNAME.DOMAIN.COM message: [LDAP: error code 49 - invalid credentials)) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    zimbra logger service is not enabled! failed.


    I've teste nameresolution for my server and it responds te right IP.


    I've run all of the following commands still with no success:
    /opt/zimbra/bin/zmcertmgr createca -new
    /opt/zimbra/bin/zmcertmgr deployca -localonly
    /opt/zimbra/bin/zmcertmgr createcrt self -new
    /opt/zimbra/bin/zmcertmgr deploycrt self

    su - zimbra -c 'zmcontrol start'

    /opt/zimbra/bin/zmcertmgr deploycrt self
    /opt/zimbra/bin/zmcertmgr deployca

    su - zimbra -c 'zmupdateauthkeys'
    /opt/zimbra/bin/zmcertmgr viewdeployedcrt


    I've check the ldap process and its up and running but with something strange.

    After runing "ps auxww ! grep zimbra | grep slapd" the slapd.conf isn't loaded. I've checked and it doesn't exist. Instead it shows "opt/zimbra/data/ldap/config"

    Can someone please help?

    Thx in advance!
    Last edited by jotapsa; 03-30-2012 at 05:22 AM.

  2. #2
    Join Date
    Apr 2011
    Posts
    117
    Rep Power
    4

    Default

    you might want to check with support quickly because just yesterday i had this issue where installation proxy configs wasn't found even after reinstallation and zmsetup.pl. they deployed a template for the component, enable the component and it starts

  3. #3
    Join Date
    Mar 2012
    Posts
    2
    Rep Power
    3

    Default SOLVED - services ldap and logger failed to start

    I was able to fix the problem resetting the passwords of root ldap and zimbra ldap.

    After that I've recreated and deployed all certificates and started the server normally.

    Thank you

Similar Threads

  1. Problem with Mail Server - Need help!
    By joeleo in forum Installation
    Replies: 2
    Last Post: 03-04-2008, 12:03 PM
  2. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  3. [SOLVED] Some services doesn't start
    By Kika in forum Administrators
    Replies: 11
    Last Post: 09-17-2007, 03:15 PM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  5. Replies: 1
    Last Post: 02-22-2006, 08:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •