Results 1 to 8 of 8

Thread: Gmail To Zimbra server produces relay access denied

  1. #1
    Join Date
    Mar 2012
    Posts
    4
    Rep Power
    3

    Default Gmail To Zimbra server produces relay access denied

    I followed to the T the instructions from the wiki on how to install Zimbra on Ubuntu and it smoothly without any hiccup.

    I also assume that the DNS configuration on the wiki is similar to the Split DNS wiki. dig domain.com MX and dig.domain.com ANY gave noerrors.

    My Zimbra server is behind a router on a fixed ip and my internet is ADSL dynamic IP and Dyndns configured into the router to update. I have ports 25 and 587 forwarded to my server.

    My problem is that I can't receive external mail. Mail within my hostname is fine, but no external mail is received.


    connect from mail-iy0-f180.google.com[209.85.210.180]
    Mar 26 21:14:24 mail-server postfix/smtpd[2977]: setting up TLS connection from mail-iy0-f180.google.com[209.85.210.180]
    Mar 26 21:14:24 mail-server postfix/smtpd[2977]: Anonymous TLS connection established from mail-iy0-f180.google.com[209.85.210.180]: TLSv1 with cipher RC4-MD5 (128/128 bits)
    Mar 26 21:14:25 mail-server postfix/smtpd[2977]: NOQUEUE: reject: RCPT from mail-iy0-f180.google.com[209.85.210.180]: 554 5.7.1 <sean@babyblue.homebeer.net>: Relay access denied; from=<sean.c.kang@gmail.com> to=<sean@babyblue.homebeer.net> proto=ESMTP helo=<mail-iy0-f180.google.com>
    Mar 26 21:14:25 mail-server postfix/smtpd[2977]: disconnect from mail-iy0-f180.google.com[209.85.210.180]

    That is the error that I get.

    I have searched the net for 2 days and I still can't find an answer. Please help.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Remeron View Post
    I also assume that the DNS configuration on the wiki is similar to the Split DNS wiki.
    That would depend on which wiki article you used.

    Quote Originally Posted by Remeron View Post
    dig domain.com MX and dig.domain.com ANY gave noerrors.
    Then you should provide the output of all the commands in the 'Verify...' section of the Split DNS article for confirmation.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2012
    Posts
    4
    Rep Power
    3

    Default

    Thanks for the quick reply.

    the output for dig

    Code:
    ; <<>> DiG 9.4.2-P2.1 <<>> singapore-clinic.com MX
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27846
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;singapore-clinic.com.		IN	MX
    
    ;; ANSWER SECTION:
    singapore-clinic.com.	604800	IN	MX	10 mail-server.singapore-clinic.com.
    
    ;; AUTHORITY SECTION:
    singapore-clinic.com.	604800	IN	NS	mail-server.singapore-clinic.com.
    
    ;; ADDITIONAL SECTION:
    mail-server.singapore-clinic.com. 604800 IN A	192.168.1.186
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.186#53(192.168.1.186)
    ;; WHEN: Mon Mar 26 22:35:46 2012
    ;; MSG SIZE  rcvd: 96
    Code:
    ; <<>> DiG 9.4.2-P2.1 <<>> singapore-clinic.com ANY
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37289
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;singapore-clinic.com.		IN	ANY
    
    ;; ANSWER SECTION:
    singapore-clinic.com.	604800	IN	SOA	mail-server.singapore-clinic.com. admin.singapore-clinic.com. 70725 604800 86400 2419200 604800
    singapore-clinic.com.	604800	IN	NS	mail-server.singapore-clinic.com.
    singapore-clinic.com.	604800	IN	MX	10 mail-server.singapore-clinic.com.
    singapore-clinic.com.	604800	IN	A	192.168.1.186
    
    ;; ADDITIONAL SECTION:
    mail-server.singapore-clinic.com. 604800 IN A	192.168.1.186
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.186#53(192.168.1.186)
    ;; WHEN: Mon Mar 26 22:36:25 2012
    ;; MSG SIZE  rcvd: 154
    Last edited by phoenix; 03-26-2012 at 10:03 AM.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I did say all the commands in that section, you're missing the resolv.conf and the hosts file.

    BTW, what is the correct domain name is it the one in your DNS output or the one in the deferred message above?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Mar 2012
    Posts
    4
    Rep Power
    3

    Default

    The domain name; sean@babyblue.homebeer.net; is actually the domain name from dyndns, so it's my public ip.

    zimbra server is on mail-server.singapore-clinic.com

    The rest of the output:


    zimbra@mail-server:~$ host $(hostname)
    mail-server.singapore-clinic.com has address 192.168.1.186


    zimbra@mail-server:~$ cat /etc/resolv.conf
    search singapore-clinic.com
    nameserver 192.168.1.186

    zimbra@mail-server:~$ cat /etc/hosts
    127.0.0.1 localhost.localadmin localhost
    192.168.1.186 mail-server.singapore-clinic.com mail-server

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Remeron View Post
    The domain name; sean@babyblue.homebeer.net; is actually the domain name from dyndns, so it's my public ip.
    That's actually a sub-domain in this context.

    Does your Zimbra server actually host a domain by the name of "homebeer.net"? If it doesn't then that's likely to be your problem - it's trying to deliver an email to that domain.

    Is that a typing error in your hosts file, this is what you've posted:

    Code:
    127.0.0.1 localhost.localadmin localhost
    The highlighted word should be "localdomain".
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Mar 2012
    Posts
    4
    Rep Power
    3

    Default

    oh my goodness, jalapeno on a stick!!

    it's suppose localdomain. Arrggghhh!
    Do I need to reinstall Zimbra to make it work? Or is restarting good enough?

    By the way, homebeer.net is not hosted by Zimbra but by DYNDNS. I'm on a dynamic IP, so my router updates my public IP with DYNDNS.

    Zimbra is on mail-server.singapore-clinic.com

    As you can tell, I'm really new at this. Thanks for the help so far.

    EDIT:
    Changed the hosts file and restarted everything. It's still the same.
    How can I include homebeer.net into my mail server settings? (Am I even asking the right question?)
    Last edited by Remeron; 03-27-2012 at 07:16 AM.

  8. #8
    Join Date
    Sep 2012
    Posts
    10
    Rep Power
    3

    Default

    Was answer provided for this? I'm encountering the same issue and I can't figure out where to go or what to search on to get answer and/or help.

Similar Threads

  1. Mysql.server Does Not Start
    By carnold in forum Administrators
    Replies: 7
    Last Post: 01-16-2012, 07:13 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  3. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 12:34 PM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  5. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •