Results 1 to 8 of 8

Thread: No recibo correos externos - I do not receive external emails

Hybrid View

  1. #1
    Join Date
    Mar 2012
    Posts
    16
    Rep Power
    3

    Default No recibo correos externos - I do not receive external emails

    Greetings, I'm a little confused so I'll be brief:
    Environment: WAN --- ------ routerNAT serverZimbra
    Configurations: dnsmasq OK
    cat / etc / hosts -> 127.0.0.1 localhost.localdomain localhost
    192.168.150.16 mail.midominio.com
    cat / etc / resolv.conf -> search midominio.com
    nameserver 127.0.0.1
    Code:
    [root@mail ~]# dig midominio.com mx
    
    ; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> midominio.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14652
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;midominio.com.		IN	MX
    
    ;; ANSWER SECTION:
    midominio.com.	0	IN	MX	5 mail.midominio.com.
    
    ;; ADDITIONAL SECTION:
    mail.midominio.com.	0	IN	A	192.168.150.16
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Mar 28 00:09:19 2012
    ;; MSG SIZE  rcvd: 85
    Code:
    [root@mail ~]# dig midominio.com any
    
    ; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> midominio.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37384
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;midominio.com.		IN	ANY
    
    ;; ANSWER SECTION:
    midominio.com.	0	IN	MX	5 mail.midominio.com.
    
    ;; ADDITIONAL SECTION:
    mail.midominio.com.	0	IN	A	192.168.150.16
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Mar 28 00:11:11 2012
    ;; MSG SIZE  rcvd: 85
    Code:
    [root@mail ~]# host mail.midominio.com
    mail.midominio.com has address 192.168.150.16
    The router has a redirection of all traffic on the public IP to private, but I can not connect to port 25 by telner from outside my network, bounce mails, gmail and others do not return error messages
    log zimbra:
    Code:
    Mar 27 20:28:03 mail zmmailboxdmgr[13877]: status requested
    Mar 27 20:28:03 mail zmmailboxdmgr[13877]: status OK
    Mar 27 20:28:03 mail zmmailboxdmgr[13886]: status requested
    Mar 27 20:28:03 mail zmmailboxdmgr[13886]: status OK
    Mar 27 20:28:05 mail zmmailboxdmgr[14228]: status requested
    Mar 27 20:28:05 mail zmmailboxdmgr[14228]: status OK
    Mar 27 20:29:05 mail zmmailboxdmgr[14481]: status requested
    Mar 27 20:29:05 mail zmmailboxdmgr[14481]: status OK
    Mar 27 20:29:05 mail zmmailboxdmgr[14490]: status requested
    Mar 27 20:29:05 mail zmmailboxdmgr[14490]: status OK
    Mar 27 20:29:51 mail postfix/smtpd[14685]: connect from mail.mydominio.com[192.168.150.16]
    Mar 27 20:29:51 mail postfix/smtpd[14685]: B25BD16324D: client=mail.mydominio.com[192.168.150.16]
    Mar 27 20:29:51 mail postfix/cleanup[14689]: B25BD16324D: message-id=<1674157495.0.1332898191423.JavaMail.root@mail.mydominio.com>
    Mar 27 20:29:51 mail postfix/qmgr[2524]: B25BD16324D: from=<admin@mydominio.com>, size=600, nrcpt=1 (queue active)
    Mar 27 20:29:51 mail postfix/smtpd[14685]: disconnect from mail.mydominio.com[192.168.150.16]
    Mar 27 20:29:51 mail amavis[2246]: (02246-01) ESMTP::10024 /opt/zimbra/data/amavisd/tmp/amavis-20120327T202951-02246: <admin@mydominio.com> -> <arunn17817@gmail.com> SIZE=600 Received: from mail.mydominio.com ([127.0.0.1]) by localhost (mail.mydominio.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <arunn17817@gmail.com>; Tue, 27 Mar 2012 20:29:51 -0500 (COT)
    Mar 27 20:29:51 mail amavis[2246]: (02246-01) Checking: 0V+vBg7aLRGC MYNETS [192.168.150.16] <admin@mydominio.com> -> <arunn17817@gmail.com>
    Mar 27 20:29:52 mail postfix/smtpd[14697]: connect from localhost.localdomain[127.0.0.1]
    Mar 27 20:29:52 mail postfix/smtpd[14697]: 1ED5E163254: client=localhost.localdomain[127.0.0.1]
    Mar 27 20:29:52 mail postfix/cleanup[14689]: 1ED5E163254: message-id=<1674157495.0.1332898191423.JavaMail.root@mail.mydominio.com>
    Mar 27 20:29:52 mail postfix/qmgr[2524]: 1ED5E163254: from=<admin@mydominio.com>, size=1065, nrcpt=1 (queue active)
    Mar 27 20:29:52 mail amavis[2246]: (02246-01) FWD via SMTP: <admin@mydominio.com> -> <arunn17817@gmail.com>,BODY=7BIT 250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 1ED5E163254
    Mar 27 20:29:52 mail amavis[2246]: (02246-01) Passed CLEAN, MYNETS LOCAL [192.168.150.16] [192.168.150.16] <admin@mydominio.com> -> <arunn17817@gmail.com>, Message-ID: <1674157495.0.1332898191423.JavaMail.root@mail.mydominio.com>, mail_id: 0V+vBg7aLRGC, Hits: -2.91, size: 600, queued_as: 1ED5E163254, 400 ms
    Mar 27 20:29:52 mail postfix/smtp[14690]: B25BD16324D: to=<arunn17817@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.48, delays=0.07/0.01/0.01/0.4, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 1ED5E163254)
    Mar 27 20:29:52 mail postfix/qmgr[2524]: B25BD16324D: removed
    Mar 27 20:29:52 mail amavis[2246]: (02246-01) extra modules loaded: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Mar 27 20:29:53 mail postfix/smtp[14698]: 1ED5E163254: to=<arunn17817@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.47.26]:25, delay=1.6, delays=0.07/0.01/0.45/1.1, dsn=2.0.0, status=sent (250 2.0.0 OK 1332898059 h26si689290anm.167)
    Mar 27 20:29:53 mail postfix/qmgr[2524]: 1ED5E163254: removed
    Mar 27 20:30:01 mail zimbramon[14724]: 14724:info: 2012-03-27 20:30:01, QUEUE: 0 0
    Mar 27 20:30:06 mail zmmailboxdmgr[15230]: status requested
    Mar 27 20:30:06 mail zmmailboxdmgr[15230]: status OK
    Mar 27 20:30:07 mail zmmailboxdmgr[15457]: status requested
    Mar 27 20:30:07 mail zmmailboxdmgr[15457]: status OK
    Mar 27 20:30:07 mail zmmailboxdmgr[15466]: status requested
    Mar 27 20:30:07 mail zmmailboxdmgr[15466]: status OK
    Code:
    Mar 27 20:41:24 mail zmmailboxdmgr[21443]: status requested
    Mar 27 20:41:24 mail zmmailboxdmgr[21443]: status OK
    Mar 27 20:41:28 mail postfix/smtpd[14697]: timeout after END-OF-MESSAGE from localhost.localdomain[127.0.0.1]
    Mar 27 20:41:28 mail postfix/smtpd[14697]: disconnect from localhost.localdomain[127.0.0.1]
    Mar 27 20:42:05 mail zmmailboxdmgr[21969]: status requested
    Mar 27 20:42:05 mail zmmailboxdmgr[21969]: status OK
    Mar 27 20:42:26 mail zmmailboxdmgr[22198]: status requested
    Mar 27 20:42:26 mail zmmailboxdmgr[22198]: status OK
    Mar 27 20:42:26 mail zmmailboxdmgr[22207]: status requested
    Mar 27 20:42:26 mail zmmailboxdmgr[22207]: status OK
    Mar 27 20:43:27 mail zmmailboxdmgr[22491]: status requested
    Mar 27 20:43:27 mail zmmailboxdmgr[22491]: status OK
    Mar 27 20:43:27 mail zmmailboxdmgr[22500]: status requested
    Mar 27 20:43:27 mail zmmailboxdmgr[22500]: status OK
    Please if anyone has any ideas, I will help.
    Gracias de ante mano a todos !!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by arunn17817 View Post
    Greetings, I'm a little confused so I'll be brief:
    Environment: WAN --- ------ routerNAT serverZimbra
    Configurations: dnsmasq OK
    cat / etc / hosts -> 127.0.0.1 localhost.localdomain localhost
    192.168.150.16 mail.midominio.com
    The highlighte line is incorrect, it should look like this:

    Code:
    192.168.150.16 mail.midominio.com mail
    Quote Originally Posted by arunn17817 View Post
    The router has a redirection of all traffic on the public IP to private, but I can not connect to port 25 by telner from outside my network, bounce mails, gmail and others do not return error messages
    That would indicate a problem with your NAT router, either the port is not open or it's not being forwarded to your LAN IP.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2012
    Posts
    16
    Rep Power
    3

    Default

    Quote Originally Posted by phoenix View Post
    The highlighte line is incorrect, it should look like this:

    Code:
    192.168.150.16 mail.midominio.com mail
    That would indicate a problem with your NAT router, either the port is not open or it's not being forwarded to your LAN IP.
    Hi phoenix,
    Thank you for your prompt response, it seems that solves the problem. It was the firewall operating system, which in my case is 64bit centos 6. I have not changed any of the settings I've shown, only opened the ports SMTP, IMAP and POP3 ("small detail") and received emails from the exterior properly.
    carries out, more tests to verify everything and I tell them but thinks he is a good point if the configuration is correct that hangs.
    A and by the way I was able to telnet to port 25!
    Thank you very much for your collaboration

    No hablo ingles, asi que disculpen si no se entiende muy bien lo que digo pues es traducido... Gracias !!!

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by arunn17817 View Post
    No hablo ingles, asi que disculpen si no se entiende muy bien lo que digo pues es traducido... Gracias !!!
    Yes, I did understand and you're welcome. Don't forget to make the change to your hosts file that I mentioned, it is important.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Mar 2012
    Posts
    16
    Rep Power
    3

    Default Solucionado - No recibo correos externos -

    Quote Originally Posted by phoenix View Post
    Yes, I did understand and you're welcome. Don't forget to make the change to your hosts file that I mentioned, it is important.
    Ok Thanks, I have been tested and so far there is no other problem. I actually made ​​the switch say to me in the host file.
    Then we can fix the problem.

    Many thanks for your kind attention.

    Ok Gracias, ha he hecho las pruebas y por el momento no hay ningún otro inconveniente. Efectivamente he hecho el cambio que me dices en el archivo de host.
    Entonces podemos dar por solucionado el problema.

    Muchísimas gracias por tu amable atención.

  6. #6
    Join Date
    Mar 2012
    Posts
    5
    Rep Power
    3

    Default

    for my case, can i change /etc/hosts file from
    Code:
    mail.mydomain.com mail
    to
    Code:
    mydomain.com mail
    cos every time reboot my server, the hostname 'mail' will disappear at the end of the line?

Similar Threads

  1. can receive external mail. Cannot send external email.
    By mwynne in forum Administrators
    Replies: 3
    Last Post: 02-24-2012, 10:17 AM
  2. Outlook. Receive but cannot Send emails
    By mickbg in forum Zimbra Connector for Outlook
    Replies: 5
    Last Post: 05-16-2011, 09:57 PM
  3. Replies: 13
    Last Post: 04-01-2011, 06:05 AM
  4. Receive Date issue with imported emails
    By bhwong in forum Migration
    Replies: 1
    Last Post: 02-15-2011, 01:04 AM
  5. I cannot receive emails...
    By c.k.winslow in forum General Questions
    Replies: 1
    Last Post: 01-23-2011, 09:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •