Results 1 to 3 of 3

Thread: Tomcat Issue

  1. #1
    Join Date
    Nov 2006
    Posts
    7
    Rep Power
    8

    Default Tomcat Issue

    I'm testing Zimbra for possible use.

    Its been running fine for about 36 hours.. started and stopped it, been doing testing. It looks like someone at work might have unplugged the test box and plugged it back in. Now Tomcat won't start.

    CentOS 4.3
    zimbra-ldap-4.0.4_GA_457.RHEL4-20061115172006
    zimbra-store-4.0.4_GA_457.RHEL4-20061115172006
    zimbra-core-4.0.4_GA_457.RHEL4-20061115172006
    zimbra-logger-4.0.4_GA_457.RHEL4-20061115172006
    zimbra-snmp-4.0.4_GA_457.RHEL4-20061115172006
    zimbra-apache-4.0.4_GA_457.RHEL4-20061115172006
    zimbra-mta-4.0.4_GA_457.RHEL4-20061115172006
    zimbra-spell-4.0.4_GA_457.RHEL4-20061115172006

    [zimbra@zimbra redolog]$ zmcontrol status
    Host zimbra.liquidweb.com
    antispam Running
    antivirus Running
    imapproxy Running
    ldap Running
    logger Running
    mailbox Stopped
    tomcat is not running
    mta Running
    snmp Running
    spell Running


    I checked permissions on redo.log
    -rw-r----- 1 zimbra zimbra 1376342 Nov 23 16:36 redo.log

    And I have stopped zimbra, cleared old pid files, and restarted... no luck

    Anyone know where Tomcat logs errors to?


    This is all I really see in /var/log/zimbra.log

    Nov 23 22:06:42 zimbra zmtomcatmgr[18771]: status requested
    Nov 23 22:06:42 zimbra zmtomcatmgr[18771]: stale pid 17171 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
    Nov 23 22:06:42 zimbra zmtomcatmgr[18771]: assuming no other instance is running
    Nov 23 22:06:42 zimbra zmtomcatmgr[18771]: no manager process is running
    Nov 23 22:06:42 zimbra zmtomcatmgr[18778]: start requested
    Nov 23 22:06:42 zimbra zmtomcatmgr[18778]: checking if another instance of manager is already running
    Nov 23 22:06:42 zimbra zmtomcatmgr[18778]: stale pid 17171 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
    Nov 23 22:06:42 zimbra zmtomcatmgr[18778]: assuming no other instance is running
    Nov 23 22:06:42 zimbra zmtomcatmgr[18779]: wrote manager pid 18779 to /opt/zimbra/log/zmtomcatmgr.pid
    Nov 23 22:06:42 zimbra zmtomcatmgr[18779]: manager started tomcat/JVM with pid 18780
    Nov 23 22:06:46 zimbra zmtomcatmgr[18779]: manager woke up from wait on tomcat/JVM with pid 18780
    Nov 23 22:06:46 zimbra zmtomcatmgr[18779]: manager started tomcat/JVM with pid 18790
    Nov 23 22:06:50 zimbra zmtomcatmgr[18779]: manager woke up from wait on tomcat/JVM with pid 18790
    Nov 23 22:06:50 zimbra zmtomcatmgr[18779]: tomcat/JVM exited twice in 4 seconds (tolerance=60)


    Ideas?

    -Chris

  2. #2
    Join Date
    Nov 2006
    Posts
    7
    Rep Power
    8

    Default

    Ah.....

    catalina.out

    Nov 23, 2006 10:07:30 PM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-80
    Nov 23, 2006 10:07:31 PM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-7071
    Nov 23, 2006 10:07:31 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 1180 ms
    Nov 23, 2006 10:07:31 PM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Nov 23, 2006 10:07:31 PM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.15
    Nov 23, 2006 10:07:31 PM org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
    Nov 23, 2006 10:07:31 PM org.apache.catalina.startup.HostConfig deployDescriptor
    WARNING: A docBase /opt/zimbra/apache-tomcat-5.5.15/webapps/zimbra inside the host appBase has been specified, and will be ignored
    log4j:WARN No appenders could be found for logger (org.apache.catalina.session.ManagerBase).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Fatal error: terminating: PrivilegedServlet init failed
    java.net.BindException: Address already in use
    at sun.nio.ch.Net.bind(Native Method)
    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSock etChannelImpl.java:119)
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAd aptor.java:59)
    at com.zimbra.cs.util.NetUtil.newBoundServerSocket(Ne tUtil.java:85)
    at com.zimbra.cs.util.NetUtil.reserveServerSocket(Net Util.java:108)
    at com.zimbra.cs.servlet.PrivilegedServlet.init(Privi legedServlet.java:91)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:211)
    at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1105)
    at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:932)
    at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:3915)
    at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4176)
    at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:759)
    at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:739)
    at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:524)
    at org.apache.catalina.startup.HostConfig.deployDirec tory(HostConfig.java:910)
    at org.apache.catalina.startup.HostConfig.deployDirec tories(HostConfig.java:873)
    at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:474)
    at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1118)
    at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:310)
    at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1020)
    at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
    at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
    at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
    at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:551)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:275)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:406)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at com.zimbra.cs.launcher.TomcatLauncher.start(Tomcat Launcher.java:52)
    at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatL auncher.java:74)


    What is perdition?
    perdition 17263 zimbra 4u IPv4 201224 TCP *:imap (LISTEN)
    perdition 17266 zimbra 4u IPv4 201245 TCP *:imaps (LISTEN)
    perdition 17269 zimbra 4u IPv4 201264 TCP *op3 (LISTEN)
    perdition 17272 zimbra 4u IPv4 201284 TCP *op3s (LISTEN)

  3. #3
    Join Date
    Nov 2006
    Posts
    7
    Rep Power
    8

    Default

    Well.. I'm back up and running... removed execute permission on perdition binary.. restarted... tomcat came up.

    Went into the admin console and turned off imap/pop3 proxy... restarted again.. it all works fine.

    Apparently I shouldn't have turned on imap/pop3 proxy without knowing what it does, or how it works

    I also looked at the "start order" in zmcontrol... it does say that "mailbox" (thats tomcat, right?) is supposed to start before "imapproxy". Apparently tomcat doesn't grab the ports fast enough.

    -Chris

Similar Threads

  1. Running tomcat after installation(solved)
    By mildred in forum Installation
    Replies: 0
    Last Post: 04-23-2007, 08:26 AM
  2. Replies: 2
    Last Post: 03-25-2007, 09:40 PM
  3. tomcat - macosx install - please help
    By gmsmith in forum Installation
    Replies: 3
    Last Post: 04-19-2006, 12:30 PM
  4. Intermittent issue (issue# 5852) ?
    By nick20 in forum Installation
    Replies: 1
    Last Post: 02-08-2006, 01:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •