Results 1 to 1 of 1

Thread: LDAP password change after migration

  1. #1
    Join Date
    Mar 2012
    Posts
    1
    Rep Power
    3

    Default LDAP password change after migration

    Installed zimbra 7.1.4 from scratch and migrated all the data from 7.1.2 to new server from old server.
    No problems except LDAP.

    Zimbra New version
    Release 7.1.4_GA_2555.SLES11_64_20120105094644 SLES11_64 FOSS edition.

    Zimbra Old Version
    Release 7.1.2_GA_3268.SLES11_64_20110804130756 SLES11_64 FOSS edition.

    The Problem:
    All users have old LDAP password to query zimbra GAL from outlook 2007 clients address books.After migration they are unable to query users mail addresses in outlook address book because the LDAP password has been changed.

    Tried to find some guides about changing password found two:
    Setting zimbra admin password in LDAP
    Setting zimbra admin password in LDAP - Zimbra :: Wiki

    Resetting LDAP and MySQL Passwords
    Resetting LDAP and MySQL Passwords - Zimbra :: Wiki

    No information about 7.1.4 at all. Also there are several differences between configurations 7.1.2 and 7.1.4 in /opt/zimbra/conf/localconfig.xml.

    Old Server:
    ldap_amavis_password = lm*****o
    ldap_nginx_password = lm*****o
    ldap_postfix_password = lm*****o
    ldap_replication_password = lm*****o
    ldap_root_password = lm*****o
    zimbra_ldap_password = lm*****o

    New Server:
    ldap_amavis_password = UQ******LN
    ldap_nginx_password = UQ******LN
    ldap_postfix_password = UQ******LN
    ldap_replication_password = UQ******LN
    ldap_root_password = UQ******LN
    zimbra_ldap_password = UQ******LN
    ldap_bes_searcher_password = UQ******LN (NEW VARIABLE)

    After changing all LDAP password using "zmldappasswd -a -l -n -p -r" (as described in IT Support Blog » Zimbra) all passwords looks OK. Same as the old server. Users can query mail addresses and everything.

    BUT
    as soon as the kerberos ticket expires (I think because it takes about 5 minutes for users to rain phones on IT dept.) after that NEITHER we can login to zimbra administrative page NOR users can send mail (strange thing is that they can receive mails !!!).

    Administrative page says as



    Need to find a solution to his problem really quick , any help or suggestion appreciated.
    Attached Images Attached Images

Similar Threads

  1. Failed to bind to LDAP server
    By tezarin in forum Administrators
    Replies: 4
    Last Post: 01-23-2012, 08:26 AM
  2. 'Change Password' Message
    By pcad in forum Administrators
    Replies: 0
    Last Post: 07-07-2011, 08:17 AM
  3. external LDAP, password change
    By zaf in forum Administrators
    Replies: 7
    Last Post: 04-30-2010, 04:29 AM
  4. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 02:08 AM
  5. Changing the LDAP default password
    By slurb in forum Installation
    Replies: 2
    Last Post: 01-12-2007, 05:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •