Results 1 to 5 of 5

Thread: ldap browsing with Zimbra Authentication (not anonymous/zimbra admin)?

Hybrid View

  1. #1
    Join Date
    Jan 2009
    Posts
    66
    Rep Power
    6

    Default ldap browsing with Zimbra Authentication (not anonymous/zimbra admin)?

    Is there a way to allow Zimbra users (i.e. who have accounts in the Zimbra mail servers), to browse the LDAP tree?

    I can browse the LDAP tree using zimbra admin e.g.:

    ldapsearch -D "uid=zimbra,cn=admins,cn=zimbra" -w ##### -x -H ldap://zimbraserver:389 "uid=test"

    I can also enable anonymous browsing by enabling anonymous (running as zimbra: libexec/zmldapanon -e)

    But I've tried "ldapsearch -D "uid=test,dc=people,dc=mydomain,dc=com" -w ##### -x -H ldap://zimbraserver:389 "uid=test" (mydomain.com is sanitised and not my real base DN of course)
    ldap_bind: Invalid credentials (49)

    So it looks like normal Zimbra users are unable to connect to the Zimbra LDAP tree? I just feel that having anonymous bind is not a good idea.
    Release 7.2.0_GA_2669.UBUNTU10_64 UBUNTU10_64 FOSS edition

  2. #2
    Join Date
    Apr 2011
    Posts
    117
    Rep Power
    4

    Default

    have you got this sorted out?
    i wanted to know how since i need to get owncloud to use zimbra ldap's user logins

  3. #3
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    The error clearly indicates either the DN you bound as is wrong, or the password was wrong. Zimbra definitely allows browsing for authenticated users by default, or authenticated + anonymous if you enable anonymous access.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #4
    Join Date
    Dec 2008
    Location
    Italy - Treviso
    Posts
    32
    Rep Power
    7

    Default

    I've the same problem here, what is the correct DN for a normal user ?

  5. #5
    Join Date
    Dec 2008
    Location
    Italy - Treviso
    Posts
    32
    Rep Power
    7

    Default

    Quote Originally Posted by flavio.tv View Post
    I've the same problem here, what is the correct DN for a normal user ?
    Ok, I've found it ! "uid=username,ou=people,dc=mydomain,dc=com"

Similar Threads

  1. Zimbra 6 on Ubuntu 8.04 x64 reverting to IPv6
    By nimble7 in forum Installation
    Replies: 1
    Last Post: 11-30-2010, 12:03 AM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •