Results 1 to 2 of 2

Thread: Name service error?

  1. #1
    Join Date
    Feb 2009
    Squamish, BC
    Rep Power

    Default Name service error?

    For some reason Zimbra does not seem to be able to "see" resolve the correct internal ip of itself? The Zimbra server on CentOS 5.8x has the hostname and IP, but mail is getting bounced with a "Name service error..."

    Everything seems right (see below) but maybe it's postfix that cannot "see" the correct internal IP of itself?

    I think and explanation of my mail routing will help to understand my problem/question.

    Mail to goes to my public gateway server ( which was an Astaro Security Gateway machine which also has the internal address The ASG gateway server would accept the mail for, scan and the forward internall to the Zimbra server at (

    The gateway server (ASG) at also served as DNS server for the network and would forward (outgoing) DNS requests to my ISP DNS servers. Internal ip addresses, like would be resolved by ASG correctly with the internal IP of since I could add any static or internal hosts to ASG.

    My ASG server just went down so now I am using a backup Netgear firewall/router as my gateway. It wont accept mail so port 25 (SMTP) traffic is now going straight into the Zimbra server ( at

    /var/log/zimbra.log shows mail getting to the internal Zimbra server, but getting rejected due to "Name service error..."

    status=bounced (Host or domain name not found. Name service error for type=A: Host not found)

    1: /etc/hosts contains penguin

    2: /etc/nsswitch.conf contains

    hosts: files dns

    3: /etc/resolv.conf contains


    4: I also edited postfix's and changed..

    disable_dns_lookups = yes

    and restarted Zimbra

    Some mail would get through, but most would get rejected due to not resolving "Name service error...."

    So I set back to....

    disable_dns_lookups = no

    Results of ping:

    PING ( 56(84) bytes of data.
    64 bytes from ( icmp_seq=1 ttl=64 time=0.031 ms
    64 bytes from ( icmp_seq=2 ttl=64 time=0.030 ms
    64 bytes from ( icmp_seq=3 ttl=64 time=0.030 ms
    Last edited by BigBirdy; 04-06-2012 at 02:38 PM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Two comments, the first is that you say this is a name resolution error yet you've provided no output for any dig commands on your lan. The second, it appears to me that your external DNS records are incorrect.. Output from a couple of di commands:

    dig any
    ; <<>> DiG 9.8.1-P1 <<>> any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38852
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0
    ;                        IN      ANY
    ;; ANSWER SECTION:         291     IN      MX      0         125     IN      A         125     IN      A
    ;; Query time: 38 msec
    ;; SERVER:
    ;; WHEN: Sat Apr  7 19:44:09 2012
    ;; MSG SIZE  rcvd: 88
    This output shows two A records for your domain and no A record associated with your MX record.

    dig mx
    ; <<>> DiG 9.8.1-P1 <<>> mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28401
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    ;                        IN      MX
    ;; ANSWER SECTION:         300     IN      MX      0
    ;; Query time: 47 msec
    ;; SERVER:
    ;; WHEN: Sat Apr  7 19:44:00 2012
    ;; MSG SIZE  rcvd: 56
    This confirms there's no A record for the MX.

    I'd suggest you check the Split DNS article for the correct output of these commands (internal or external) and the correct content of the hosts file and resolv.conf. You should also run all the commands in the 'Verify...' section of that article to confirm your LAN DNS configuration.


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 5
    Last Post: 05-11-2012, 02:16 PM
  2. [SOLVED] I broke my server trying to optimize... HELP!
    By myriad in forum Administrators
    Replies: 9
    Last Post: 09-17-2011, 06:46 AM
  3. Replies: 6
    Last Post: 03-14-2011, 04:21 AM
  4. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 05:49 AM
  5. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts