Results 1 to 2 of 2

Thread: Migration from OS X 6.0.15 to Debian 7.1.4

  1. #1
    Join Date
    Feb 2012
    Las Vegas
    Rep Power

    Default [SOLVED] [YAMM] Migration Guide from MacOSX/ZCS 6.0 32 to Debian/ZCS 7.1 64

    Well... this is a long one. Suffice it to say that migrating away from OS X is not a fun thing when Zimbra is involved.

    For anyone else who needs to attempt it, this was the most helpful howto:
    Platform and OS Independent ZCS to ZCS Migration Using Rsync - Zimbra :: Wiki

    It probably didn't help that I wound up going to a Debian Squeeze platform. I was going to switch to Ubuntu 10.04 LTS since that's supported, but couldn't get it to boot on the HP ProLiant server I was attempting to install to, and didn't particularly feel like hacking up a new kernel that *would* boot.

    So, long story short, I migrated from 6.0.15_GA (32-bit, OS X 10.4 Server) to 7.1.4_GA (64-bit, Debian Squeeze).

    The process involved:
    1. Rsync from OSX /opt/zimbra to /opt/zimbra.old on Debian
    2. Installing the 6.0.15_GA DEBIAN5 package
    3. Moving /opt/zimbra to /opt/
    4. Moving /opt/zimbra.old to /opt/zimbra
    5. rm /opt/zimbra/openldap-*
    6. cp -R /opt/* /opt/zimbra/
    7. following the LDAP restore steps described here
    8. doing an upgrade install of 6.0.15_GA DEBIAN5 on top of the rsync'd and ldap'd /opt/zimbra
    9. Pausing at "Saving existing configuration file to /opt/zimbra/.saveconfig
    10. Copying the ORIGINAL /opt/zimbra/config.***** to to /opt/zimbra/.saveconfig/ (I could tell it was the right one because when I did a tail on it, the last line was INSTALL_PACKAGES="zimbra-apache ... etc.). If I failed to do this step, then the Zimbra script would happily overwrite everything with a blank config and I'd be back to square 1.

    At this point, even SSL certs would get generated properly and everything installed correctly. I just had to toggle the TLS setting back with zmtlsctl afterward.

    Then I ran the 7.1.4 upgrade, and noticed that it tried to reset the config AGAIN, as in the last step I mentioned. Copied the config again, and everything just worked.

    So again, I'm not sure if the config.***** and .saveconfig shenanigans were just due to running an unsupported Debian platform, or something related to the original OSX install.

    Only current glitch is with the logging service, which I'll look into at some later point when I'm not dead tired.

    Cheers all.
    Last edited by Crayz9000; 04-23-2012 at 11:37 AM. Reason: Change title

  2. #2
    Join Date
    Feb 2012
    Las Vegas
    Rep Power

    Default [SOLVED] [YAMM] Migration Guide from MacOSX/ZCS 6.0 32 to Debian/ZCS 7.1 64

    Well, I worked out (I hope) all of the issues I had with the Debian Squeeze install, and put together YAMM here: Crayz9000-Notes - Zimbra :: Wiki

    This also includes a possible solution for people experiencing issues with server stats (the dreaded "Server status data is not available. To see the server status, logger service must be installed." message) after changing platforms and upgrading:
    Crayz9000-Notes - Zimbra :: Wiki
    Last edited by Crayz9000; 04-23-2012 at 11:38 AM. Reason: Trying to change title

Similar Threads

  1. ZCS 7.1.4 & 6.0.15 Shipped!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 01-11-2012, 03:18 PM
  2. Migration from Zimbra OS 6 to Zimbra OS 7 Problems
    By thomsany in forum Administrators
    Replies: 0
    Last Post: 12-02-2011, 07:58 AM
  3. OS Migration
    By powrrrplay in forum Administrators
    Replies: 4
    Last Post: 09-26-2011, 11:39 PM
  4. dkim filter for zimbra on Debian OS
    By ashrocks in forum Installation
    Replies: 3
    Last Post: 12-02-2010, 07:14 AM
  5. Migration from Debian to Ubuntu
    By mave28 in forum Migration
    Replies: 3
    Last Post: 05-25-2007, 06:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts