Results 1 to 1 of 1

Thread: Mi Samba server canīt contact LDAP Zimbra server

  1. #1
    Join Date
    Mar 2012
    Rep Power

    Default Mi Samba server canīt contact LDAP Zimbra server

    Hello, i have a bit problem with my new installation of zimbra + Samba

    I Hve 2 different machines. One working with zimbra and another one just with samba server.

    I've configured booth using instruction from this guide

    UNIX and Windows Accounts in Zimbra LDAP and Zimbra Admin UI - Zimbra :: Wiki

    I've make it for 3 times allways with the same result. Samba server can't contact the ldap server and i cant' see why? Any help?

    zimbra machine name:
    domain name:

    samba machine name:

    smbd Log:
    Connection to LDAP server failed for the 3 try!

    My smb.conf
    workgroup = IPARZIMBRA
    netbios name = ubuntupdc
    os level = 33
    preferred master = yes
    enable privileges = yes
    server string = %h server (Samba, Ubuntu)
    wins support =yes
    dns proxy = no
    name resolve order = wins bcast hosts
    log file = /var/log/samba/log.%m
    log level = 3
    max log size = 1000
    syslog only = no
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    security = user
    encrypt passwords = true
    ldap passwd sync = yes
    passdb backend = ldapsam:ldap://
    ldap admin dn = "uid=zimbra,cn=admins,cn=zimbra"
    ldap suffix = dc=iparzimbra,dc=com
    ldap group suffix = ou=groups

    later smbdpass -W (password from zmlocalconfig -s zimbra_ldap_password)

    But when I restart smbd i get the explained error.
    I have communication between machines, and the port 389 is open on the zimbra machine.

    I've mount different new clean machines with allways the same error, I'm becoming crazy to locate where i'm failing

    Anybody can help me? Or tols me what can I review?

    Thanks in advance.

    Some new sintoms

    if I make a telnet to 389 port in the zimbra machine works well, but if I Try it from the samba machine doesn't work

    telnet 389
    telnet: Unable to connect to remote host: Connection refused

    config from zimbra machine
    root@Zimbra:~# netstat -an |grep 389
    tcp 0 0* ESCUCHAR
    tcp 0 0 ESTABLECIDO
    tcp 0 0 ESTABLECIDO

    zimbra@Zimbra:/root$ zmlocalconfig | grep 389
    ldap_master_url = ldap://
    ldap_port = 389
    ldap_url = ldap://

    I've no iptables configured on the zimbra machine.

    More tests
    From the samba server
    root@ubuntuPDC:~# ldapsearch -H ldap:// -b dc=iparzimbra,dc=com -x -d-1
    ldap_new_connection 1 1 0
    ldap_connect_to_host: TCP
    ldap_new_socket: 3
    ldap_prepare_socket: 3
    ldap_connect_to_host: Trying
    ldap_pvt_connect: fd: 3 tm: -1 async: 0
    ldap_close_socket: 3
    ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

    ps -ef | grep slap
    zimbra 8367 1 0 10:24 ? 00:00:00 /opt/zimbra/openldap/sbin/slapd -l LOCAL0 -u zimbra -h ldap:// ldapi:/// -F /opt/zimbra/data/ldap/config

    Looking to the process that appears with the ps command i understand that sladp process starts listening ONLY localhost ( and with the nestat -na i can see That means that only accept conecctions form localhost? How can i change this?

    I come back to a previous snapshot and i configure all another time, now it seems to works

    Adding a new line to smb.conf
    ldap ssl= no
    I don't have mnore errors it' suppoused to work correctly, but Ą Surprise! Doesn't work

    when i go tho samba domains on the zimbra admin gui, y don't have there my configured domain
    if i try on the samba server getting the domain ID i get this error

    root@ubuntuPDC:~# net getlocalsid
    [2012/04/16 18:47:24, 0] lib/smbldap_util.c:310(smbldap_search_domain_info)
    smbldap_search_domain_info: Adding domain info for IPARZIMBRA failed with NT_STATUS_UNSUCCESSFUL

    I have been looking for some info about the error with no Luck Anybody can help me please.
    Last edited by jbarandalla; 04-16-2012 at 09:48 AM.

Similar Threads

  1. Mysql.server Does Not Start
    By carnold in forum Administrators
    Replies: 7
    Last Post: 01-16-2012, 06:13 AM
  2. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  3. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  4. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts