Hi,

Some of the people at my office are on the road a lot, working at customers with old browsers that don't support ajax. For these situations I want to provide them with the squirrelmail webmail client.

I got it set up ok i think, the only problem is that viewing "big" folders doesn't work. My Sent Items folder for instance, contains over 9000 messages. When Squirrelmail tries to open it, it takes around 1 minute and then it shows me the browser download file dialog for the file right_mail.php. When I save that and open it, there's nothing in it.

The zimbra.log says:

2006-11-25 14:43:59,737 INFO [ImapServer-55] [ip=10.0.0.5;name=aaa@bbb.com;] imap - [ search is: in:"INBOX" (item:all ) ]
2006-11-25 14:44:11,926 INFO [ImapServer-55] [] ProtocolHandler - Exception occurred while handling connection
java.io.IOException: Broken pipe
at sun.nio.ch.FileDispatcher.write0(Native Method)
at sun.nio.ch.SocketDispatcher.write(SocketDispatcher .java:29)
at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.jav a:104)
at sun.nio.ch.IOUtil.write(IOUtil.java:75)
at sun.nio.ch.SocketChannelImpl.write(SocketChannelIm pl.java:302)
at java.nio.channels.Channels.write(Channels.java:60)
at java.nio.channels.Channels.access$000(Channels.jav a:47)
at java.nio.channels.Channels$1.write(Channels.java:1 34)
at java.io.BufferedOutputStream.flushBuffer(BufferedO utputStream.java:65)
at java.io.BufferedOutputStream.write(BufferedOutputS tream.java:109)
at java.io.FilterOutputStream.write(FilterOutputStrea m.java:80)
at com.zimbra.cs.imap.ImapHandler.doFETCH(ImapHandler .java:1684)
at com.zimbra.cs.imap.ImapHandler.executeRequest(Imap Handler.java:394)
at com.zimbra.cs.imap.ImapHandler.processCommand(Imap Handler.java:227)
at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:231)
at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:198)
at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
at java.lang.Thread.run(Thread.java:595)
2006-11-25 14:44:11,927 INFO [ImapServer-55] [] ProtocolHandler - Handler exiting normally


Before reporting it as a bug, has anyone seen this before?
Is there a parameter I missed?

I'm running 4.5.0_BETA1_440.UBUNTU6.

Any ideas would be appreciated.

kind regards, Bart.