Results 1 to 2 of 2

Thread: Certificate Issue seems to have stopped my Zimbra server

  1. #1
    Join Date
    May 2012
    Posts
    1
    Rep Power
    3

    Default Certificate Issue seems to have stopped my Zimbra server

    I am pretty new to zimbra. I set it up to host my own email and to learn it slowly along the way. It was working perfectly until today. I received a "net work error" and did some research which seemd to point to the fact that my self made certificate had expired. I then tried to resinstall the certificate with every tutorial I could find but each one seemed to fail. I have chased many angles but cannot seem to get figure exatly what is wrong.

    Here is the the current error I am chasing:

    sudo /opt/zimbra/bin/zmcertmgr deployca
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...done.
    ** Saving global config key zimbraCertAuthorityCertSelfSigned...failed.
    ** Saving global config key zimbraCertAuthorityKeySelfSigned...failed.
    ** Copying CA to /opt/zimbra/conf/ca...done.

    I cannot find any mention of this error in any log files. Can someone point me to the log file that contains this type of errors? Hopefully there will be something in there that tells me what is going wrong.

  2. #2
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    7

    Default

    It's kind of a catch-22 situation because it needs to use those certificates to connect to ldap in order to change them.

    What you need to do is:
    Code:
    zmlocalconfig -e ssl_allow_untrusted_certs=true
    zmcontrol restart
    on each box first, then deploy your new certificates. Once the new certs are deployed you can set it back to false again.

Similar Threads

  1. fatal: parameter "smtpd_recipient_restrictions"
    By Robin in forum Administrators
    Replies: 8
    Last Post: 12-22-2010, 05:48 AM
  2. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  3. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •