Results 1 to 4 of 4

Thread: domain alias: email answers issue

  1. #1
    Join Date
    May 2012
    Posts
    4
    Rep Power
    3

    Default domain alias: email answers issue

    Hi all,
    I have the "company.com" domain and the alias "company.it".

    When "somebody@company.com" writes to "myself@company.it" the email arrives to my inbox. So simple.. but the destination appears as ".it", so if I try to answer the zimbra-webclient keeps "myself@company.it" in the "cc" fields.

    It seems to me that the zimbra-webclient feels "myself@company.it" as a different address, not the mine.
    To solve I created the single alias "myself@company.it" => "myself@company.com", and it works (yes, it is quite annoying: I already made the domain alias! but it works)


    But I have the same problem with the other clients (thunderbird, smarthphone, etc.). I configure thunderbird for "myself@company.com", so it keeps "myself@company.it" in the "cc" field, and I can do nothing to solve the problem (in the client-side).


    Nobody else had this problem?
    I think the best solution is to rewrite the "To: xx" header in order to switch from ".it" to ".com" before the email arrives in the inbox, but I don't know how I can do.
    Can the "Domain Masquerading" solve this problem? Or can I add an external header filter,made by myself? Or.. any other idea will be appreciated.

    Thanks

  2. #2
    Join Date
    May 2012
    Posts
    4
    Rep Power
    3

    Default

    Postfix "recipient_canonical_maps" resolves the problem:

    content of /opt/zimbra/conf/recip
    /^([^@]+)@company\.it$/ ${1}@company.com

    postmap /opt/zimbra/conf/recip
    postconf -e recipient_canonical_maps=regexp:/opt/zimbra/conf/recip
    postfix reload

    et voilà... The local destination address "@company.it" is rewritten in "@company.com" in all the emails.
    And I don't need the single aliases for each account anymore.

    I will have to pay attenction to the future zimbra updates, they should overwrite my trick.

  3. #3
    Join Date
    May 2012
    Posts
    4
    Rep Power
    3

    Default

    No, it seems working only for clients in "$mynetwork" environment. For all other clients (all the world, as far the server will have the mx record referring to it) it doesnt' rewrite the adresses.

    As far this is a postfix related question I will post it on the postfix mailing list.

    Thanks

  4. #4
    Join Date
    May 2012
    Posts
    4
    Rep Power
    3

    Default

    postconf -e remote_header_rewrite_domain=company.it

    Finish (I hope..)

Similar Threads

  1. Help, Can't send email to external domain
    By andekhi in forum Administrators
    Replies: 2
    Last Post: 11-03-2011, 01:27 AM
  2. Disable a domain without deleting email?
    By shankwc in forum Administrators
    Replies: 3
    Last Post: 09-21-2010, 01:16 AM
  3. Migrating domain issue
    By albanach in forum Installation
    Replies: 1
    Last Post: 01-18-2008, 10:35 AM
  4. Two email servers in the same domain
    By Marcelo Gonzalez in forum Installation
    Replies: 0
    Last Post: 04-24-2007, 09:59 AM
  5. domain alias as sender
    By coreASP in forum Administrators
    Replies: 1
    Last Post: 05-21-2006, 06:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •