Hi,

my zimbra.log is always repeating this:


May 11 15:00:10 mail postfix/smtpd[29901]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:00:15 mail postfix/smtpd[29901]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:00:44 mail postfix/smtpd[31638]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:00:49 mail postfix/smtpd[31638]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:01:13 mail postfix/smtpd[29901]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:02:24 mail postfix/smtpd[31638]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:06:42 mail postfix/smtpd[34427]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:06:43 mail postfix/smtpd[34430]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:06:51 mail postfix/smtpd[34427]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:07:15 mail postfix/smtpd[34430]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:07:34 mail postfix/smtpd[34427]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com
May 11 15:08:07 mail postfix/smtpd[34430]: warning: x.x.x.x(public IP): address not listed for hostname mail.domain.com


dig test:


[root@mail ~]# dig domain.com any

; <<>> DiG 9.7.0-P2-RedHat-9.7.0-5.P2.el6 <<>> domain.com any
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 48297
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;domain.com. IN ANY

;; ANSWER SECTION:
domain.com. 38400 IN MX 10 mail.domain.com.
domain.com. 38400 IN SOA y.y.y.y(private ip). admin.domain.com. 1335201476 10800 3600 604800 38400
domain.com. 38400 IN NS y.y.y.y(private ip).

;; ADDITIONAL SECTION:
mail.domain.com. 38400 IN A y.y.y.y(private ip)

;; Query time: 3 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri May 11 15:19:08 2012
;; MSG SIZE rcvd: 141

why is resolving with the public ip, I've set my server with private ip, in my router I have two ip's, one of them is the public and is used only for my mail server