Results 1 to 2 of 2

Thread: 451 4.7.1 Service unavailable - try again later (in reply to end of DATA....

Hybrid View

  1. #1
    Join Date
    Sep 2005
    Posts
    48
    Rep Power
    10

    Default 451 4.7.1 Service unavailable - try again later (in reply to end of DATA....

    Server version: 7.1.2_GA_3268.UBUNTU10_64 UBUNTU10_64 FOSS edition

    We are getting some emails returned as undeliverable by our server with the following message,

    Code:
    host mail.our-zimbra-server-domain.com[xx.xx.xx.xx] said: 451
       4.7.1 Service unavailable - try again later (in reply to end of DATA
       command)
    My first guess was that the emails had unusually long attachements that was causing a timeout before the DATA section had completed. However people are reporting that their emails to us are bounced with a size less than 2MB.

    I put a watch on the zimbra.log for anything with the word "timeout" in it. There are lots of messages like...
    Code:
    May 14 17:27:48 mail postfix/smtpd[17009]: timeout after END-OF-MESSAGE from localhost[127.0.0.1]
    ...and a few like...
    Code:
    May 14 05:57:31 mail postfix/smtpd[16856]: timeout after DATA (7008 bytes) from unknown[.....
    However none of these timeout messages involves one of the IP addresses involved in a sender who has confirmed they were getting their email bounced from us. There doesn't seem to be anything obvious in the logs when it happens, although I am still searching around the date/time of the rejections.

    Simply egrepping for "[^0-9]451[^0-9]" doesn't show anything except an unlrelated mention of the number "451".

    Our Zimbra server is running on a VSpere 5/SAS/SATA environment on a Dell 2950.

    I would appreciate some ideas on what might be causing these timeouts and where they would be reported if not in zimbra.log.

  2. #2
    Join Date
    Sep 2005
    Posts
    48
    Rep Power
    10

    Default

    OK, now I've had some more time to look at the issue, I've found the occurance in the log files.

    Code:
    May 14 11:06:11 mail postfix/cleanup[29709]: warning: milter inet:127.0.0.1:7026: can't read SMFIC_HEADER reply packet header: Success
    May 14 11:06:11 mail postfix/cleanup[29709]: 4381A2017D3: milter-reject: END-OF-MESSAGE from gateway04.someothermailserver.com[xx.xx.xx.xx]: 4.7.1 Service unavailable - try again later; from=<don@othermail.com> to=<me@ourzimbra.com> proto=ESMTP helo=<gateway04.someothermailserver.com>
    May 14 11:06:11 mail postfix/smtpd[27688]: disconnect from gateway04.someothermailserver.com[xx.xx.xx.xx]
    I have found another thread regarding this issue.
    http://www.zimbra.com/forums/adminis...r-timeout.html

    I have tried the solution suggested by FritzBrause,
    Code:
    zmlocalconfig -e milter_thread_keep_alive_time=120
    zmlocalconfig -e milter_write_timeout=30
    zmcontrol restart
    Let's see if it helps.

Similar Threads

  1. message refused (in reply to end of DATA)
    By reza225 in forum Administrators
    Replies: 2
    Last Post: 02-03-2014, 11:06 AM
  2. [SOLVED] Lot of mails deferred
    By pigui in forum Administrators
    Replies: 17
    Last Post: 04-10-2012, 06:15 AM
  3. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 12:44 PM
  4. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  5. Replies: 3
    Last Post: 07-19-2007, 03:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •