Results 1 to 2 of 2

Thread: Commercial Certificate RapidSSL

  1. #1
    Join Date
    Jun 2012
    Rep Power

    Default Commercial Certificate RapidSSL

    I have been having problems trying to install a Commercial Certificate from GeoTrust - RapidSSL, I can generate the CSR no problem and process the certificate at GeoTrust but when verifying the certificated I receive
    XXXXX ERROR: Unmatching certificate (/opt/zimbra/ssl/zimbra/commercial/commercial.crt) and private key (/opt/zimbra/ssl/zimbra/commercial/commercial.key) pair.
    I have tried using the command line and GUI without any success.
    I have been following the wiki and other resources in the forum without any luck.
    The process I have been using is.

    Generate the CSR
    sudo /opt/zimbra/bin/zmcertmgr createcsr comm -new "/C=US/ST=TX/L=Somewhere/O=Company, Inc./OU=ChangeMe, Inc./CN=mail.CHANGEME.zxy"
    Obviously using my appropriate details.
    This creates the CSR in /opt/zimbra/ssl/zimbra/commercial/commercial.csr

    Submit CSR to RapidSSL
    NOTE: during the certificate process at GeoTrust I selected "other" as the server type, could this be a problem?
    Once the administrator email address has been verified a email is received with two digital certificates, one is the INTERMEDIATE CA and other your digital cert(im not sure what this certificate is called).
    Saved the digital certificate into /opt/zimbra/ssl/zimbra/commercial/commercial.crt (from memory there was already a file here, replaced contents)
    Then according to this wiki post we need to download the Geotrust root certificate and the RapidSSL_CA_bundle and combine them into a files called ca_bundle.crt
    Saved this ca_bundle.crt into /opt/zimbra/ssl/zimbra/commercial

    Verify the Certificate and Keys match
     sudo /opt/zimbra/bin/zmcertmgr verifycrt comm /opt/zimbra/ssl/zimbra/commercial/commercial.key /opt/zimbra/ssl/zimbra/commercial/commercial.crt
    This is when I receive the error mentioned above about the certificates not matching.

    Can somebody please help me with installing this commercial digital certificate, any advice or pointers will help
    Last edited by haxxess; 06-08-2012 at 11:09 AM.

  2. #2
    Join Date
    Oct 2009
    Troy, MI
    Rep Power


    I'm having the same problem with Zimbra 8, only I'm trying to install a Thawte SSL cert...

Similar Threads

  1. rapidSSL certificate error
    By savez in forum Administrators
    Replies: 1
    Last Post: 09-07-2011, 01:32 AM
  2. [SOLVED] can't install RapidSSL certificate
    By vaidotas in forum Administrators
    Replies: 2
    Last Post: 08-09-2011, 05:16 AM
  3. Problem with install RapidSSL Certificate
    By MrSnaKe in forum Administrators
    Replies: 2
    Last Post: 09-17-2009, 02:00 AM
  4. SSL commercial certificate
    By Mudasar in forum Administrators
    Replies: 0
    Last Post: 10-09-2008, 12:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts