Results 1 to 2 of 2

Thread: LDAP failed to start server down

Hybrid View

  1. #1
    Join Date
    Jun 2012
    Rep Power

    Default [SOLVED]LDAP failed to start server down

    Hi all,

    first i hope this thread is in the good section of the forum, if not i am sorry.

    My server crashed yesterday. This server is up and running for almost 2 years with only minor problems.

    I am experiencing a strange issue. The services refuse to start with the known error when i try a zmcontrol status :
    unable to determine enabled services from ldap
    unable to determine enabled services. Cache is out of date or doesn't exist.

    I already had this problem when my certificate was out of date.

    So i did as i did before : i create a new certificate.

    The i experience many issue concerning the zimbraSSLPrivateKey and the zimbraSSLPrivateCertificate. when zmcertmgr try to deploy or create the certificate i got the same error :
    unable to load certificate
    18212:error:0906D06C:PEM routine:PEM_read_bio:no start lineem_lib.c:650:Expecting: TRUSTED CERTIFICATE

    I try everything i found in the wiki and the forum with no success.

    I need some guidance here.

    for informations i use the ZCS 6.0.8_GA_2661 for ubuntu 10.04 LTS x64 server
    This server was running properly for almost 2 years, no specific crash appear prior to this one.
    Last edited by gourou; 06-10-2012 at 10:56 PM.

  2. #2
    Join Date
    Jun 2012
    Rep Power



    it was not a problem of certificate or of network, it was a problem of the LDAP database that was corrupt. I simply needed to do go to my backup folder, and restore the LDAP database from the last backup, restart all services and everything was back to normal.

Similar Threads

  1. services ldap and logger failed to start
    By jotapsa in forum Administrators
    Replies: 2
    Last Post: 03-30-2012, 04:21 AM
  2. Failed to bind to LDAP server
    By tezarin in forum Administrators
    Replies: 4
    Last Post: 01-23-2012, 08:26 AM
  3. ldap start failed
    By tiger2000 in forum Administrators
    Replies: 1
    Last Post: 02-23-2010, 05:06 PM
  4. LDAP failed after i changed my server
    By crowley in forum Installation
    Replies: 3
    Last Post: 02-03-2009, 02:37 AM
  5. Replies: 1
    Last Post: 02-22-2006, 07:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts