I'm having a very big yet very little issue and was wondering if there was anyone out there that could shed some light on this problem I'm having. We have ZCS 7.2 running in our production environment on Ubuntu 10.04, but as a beta. Basically, if anyone wants to test it out they can, and their input will help when we finally turn off the lights on our old Exchange 2003 box. Right now everything is working fine, except for reverse proxying to zimbramail.example.com through another Ubuntu 10.04 Box just running Apache, zimbraproxy.example.com. The zimbraproxy.example.com box will be placed in the DMZ once I get these kinks worked out. Browsing to zimbraproxy with Firefox works flawlessly. IE 8 or 9, after getting past the VMware login page, it hangs loading the Ajax interface, and then finally musters up enough energy to get past it. Google Chrome doesn't like the reverse proxy at all, and basically comes to a standstill once loading the Ajax interface. The standard HTML pages work fine for both IE and Chrome. But that is not an option, as my boss absolutely loves the Ajax view. The Main Zimbra server is using Jetty.

I do not just want to abandon my Ubuntu 10.04 Apache Reverse Proxy because I know it is so close to working. Worked through the HTTPS issues and the BAD_JSON_RESPONSE errors with modifications to my proxy config seen here.

Here is my Apache Virtual Host File on zimbraproxy.example.com

<VirtualHost *:443>
#SecFilterEngine Off (This didn't seem to like my apache)
SetEnv force-proxy-request-1.0 1
SetEnv proxy-nokeepalive 1

ServerName zimbraproxy.example.com
SSLEngine on
SSLProtocol all
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSL v2:+EXP:+eNULL
SSLCertificateFile /etc/apache2/ssl/server.crt
SSLCertificateKeyFile /etc/apache2/ssl/server.key

SSLProxyEngine on
SSLProxyCACertificateFile /etc/apache2/ssl/server.crt

#RequestHeader set Front-End-Https On (This also did not like my apache)
ProxyRequests On
ProxyPreserveHost On
ProxyVia full

<Proxy *>
Order deny,allow
Allow from all
</Proxy>

ProxyPass / https://zimbramail.example.com/
ProxyPassReverse / https://zimbramail.example.com/

ErrorLog /var/log/apache2/error.log

</VirtualHost>

Also in the httpd.conf file itself I have this defined:

<VirtualHost *:80>
RewriteEngine on
ReWriteCond %{SERVER_PORT} !^443$
RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]
</VirtualHost>

In order for end users to not have to remember "https" infront of the subdomain zimbramail.example.com.

The commands I ran to enable modules within apache are as follows:
a2enmod proxy
a2enmod ssl
a2enmod rewrite
a2enmod proxy_http

Anyone that could shed some light on this would make my month!!!