Results 1 to 3 of 3

Thread: XMPP server closed the connection with Pidgin

Hybrid View

  1. #1
    Join Date
    Aug 2010
    Rep Power

    Post [SOLVED] XMPP server closed the connection with Pidgin


    I have one user that can't connect to the Zimbra IM Server.

    When Pidgin connecting, it just disconnect straight, saying "Server closed the connection".

    However, this user can connect throught Zimbra Web Interface to XMPP.

    I tried restarting Zimbra services, but it didn't solved the problem

    This only happening to one user, others are connecting fine.

    Here is the only trace logs I have found in mailbox.log :

    <iq type="result" id="purplecb0c92d0" to="">
    <iq type="result" id="purplecb0c92d1" from="" to="">
    <iq type="error" id="purplecb0c92d2" from="" to="">
    <iq type="result" id="purplecb0c92d3" from="" to="">
    <iq type="result" id="purplee2c40a7c" to="">

    [For the next log, I'm not sure it happened when the user tried to connect to XMPP, but I think so]

    2012-06-15 10:48:59,314 ERROR [AnonymousIoService-10] [] im - Impossible de fermer le socket 6682d439
    at java.nio.charset.CoderResult.throwException(CoderR
    at org.apache.mina.common.ByteBuffer.putString(ByteBu
    at java:111)
    at 12)
    at se(
    at iver(
    at dler.process(
    at org.jivesoftware.wildfire.spi.PacketDelivererImpl. deliver(
    at org.jivesoftware.wildfire.handler.IQHandler.proces s(
    at org.jivesoftware.wildfire.IQRouter.handle(IQRouter .java:274)
    at org.jivesoftware.wildfire.IQRouter.route(IQRouter. java:103)
    at org.jivesoftware.wildfire.spi.PacketRouterImpl.rou te(
    at IQ(
    at rocessIQ(
    at (
    at ss(
    at adCompleted(
    at$Nio IoHandlerAdapter.messageReceived(NioAcceptingMode. java:93)
    at in$TailFilter.messageReceived(AbstractIoFilterChai
    at in.callNextMessageReceived(AbstractIoFilterChain.j ava:299)
    at in.access$1100(
    at in$EntryImpl$1.messageReceived(AbstractIoFilterCha
    at eduledEvents(
    at org.apache.mina.filter.SSLFilter.messageReceived(S
    at in.callNextMessageReceived(AbstractIoFilterChain.j ava:299)
    at in.access$1100(
    at in$EntryImpl$1.messageReceived(AbstractIoFilterCha
    at cessEvent(
    at org.apache.mina.filter.executor.ExecutorFilter$Pro
    at java.util.concurrent.ThreadPoolExecutor$ Task(
    at java.util.concurrent.ThreadPoolExecutor$ (
    2012-06-15 10:48:59,316 WARN [AnonymousIoService-10] [] im - Impossible d'orienter ce paquet

    Not very useful
    Last edited by Kidoucorp; 06-19-2012 at 05:12 AM. Reason: Problem solved

  2. #2
    Join Date
    Jun 2012
    Rep Power



    Facing the same issue, we have a user that was sending to users that can't connect a very big message.
    Connecting to xmpp via the HTTP interface solved the issue as the message get delivered when connected via the web interface.

  3. #3
    Join Date
    Aug 2010
    Rep Power


    Thanks for your answer.

    I just managed to get it working again. It seems that this user changed is "Avatar" with a strange image. Looking at the logs, when connecting with Pidgin, he was sending an image of type "PNG", while his image was a GIF.

    I managed to connect to his account with the Spark Client. It was working ok. But When I tried to connect at the same time, same account with Pidgin (Using different Resources), I was disconnected from Spark as well.

    What I did is connecting to the blocked account with Spark, changing his Avatar to something "standard", and then, the problem disapeared.

    I could connect with Pidgin, Spark (even at the same time), without any problem.

    Very strange. Don't know if it's a Pidgin's bug or Zimbra's one... But the problem was the image, for sure

    Anyway, solved !!!

Similar Threads

  1. connection is closed
    By bipbip293 in forum Error Reports
    Replies: 0
    Last Post: 08-30-2011, 08:35 AM
  2. Replies: 3
    Last Post: 12-20-2010, 10:49 AM
  3. Connection is closed
    By godric_gt in forum Error Reports
    Replies: 3
    Last Post: 04-29-2009, 11:59 PM
  4. Instant Messenger - Connection Problems from Pidgin
    By mtapman in forum Administrators
    Replies: 2
    Last Post: 11-26-2008, 12:56 PM
  5. Replies: 3
    Last Post: 06-11-2008, 06:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts