Results 1 to 3 of 3

Thread: Disabling IM/XMPP in ZCS 7.x

  1. #1
    Join Date
    Feb 2012
    Location
    Las Vegas
    Posts
    65
    Rep Power
    3

    Default Disabling IM/XMPP in ZCS 7.x

    I have a bit of a strange issue. Back when I was playing with ZCS 6 on OSX, I had enabled IM to try. Now that I've already migrated and upgraded to ZCS 7 (first it was 7.1.4, now 7.2.0) I find that I can't make the IM user interface elements go away:

    IM_ZCS7.png

    Before upgrading from 7.1.4 to 7.2.0 yesterday, I read through Ajcody-Instant-Messaging-Topics - Zimbra :: Wiki and disabled XMPP as described. To be safe, I also made sure that zimbraFeatureInstantNotify and zimbraFeatureIMEnabled were also turned off:

    Code:
    zimbra@mail:~/libexec$ zmprov gc default zimbraFeatureIMEnabled
    # name default
    zimbraFeatureIMEnabled: FALSE
    
    zimbra@mail:~/libexec$ zmprov gc default zimbraFeatureInstantNotify
    # name default
    zimbraFeatureInstantNotify: FALSE
    
    zimbra@mail:~/libexec$ zmprov gacf zimbraXMPPEnabled
    zimbraXMPPEnabled: FALSE
    And before anyone asks, I have not created any additional COS entries -- there is only the default COS.

    However, I still can't get the UI elements to go away... Any ideas?
    Last edited by Crayz9000; 06-26-2012 at 01:18 PM.

  2. #2
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Hm, most people have the opposite problem, wanting to keep IM even though it's disabled by default in ZCS 7. In fact I'm surprised it didn't just go away for you.

    When I restored IM in ZCS 7, I turned on all the properties you mention above, but also zimbraPrefIMAutoLogin. So maybe if you turn that off, it would help.

    Another shot in the dark. As root:
    mv /opt/zimbra/lib/ext/zimbraiminterop /some/other/place/

    As zimbra (if ZCS is running):
    zmmailboxdctl restart

  3. #3
    Join Date
    Feb 2012
    Location
    Las Vegas
    Posts
    65
    Rep Power
    3

    Default

    Autologin was already off:

    Code:
    zimbra@mail:~$ zmprov gc default zimbraPrefIMAutoLogin
    # name default
    zimbraPrefIMAutoLogin: FALSE
    And the zimbraiminterop folder doesn't even exist...

    Code:
    zimbra@mail:~$ ls /opt/zimbra/lib/ext/zimbraiminterop
    ls: cannot access /opt/zimbra/lib/ext/zimbraiminterop: No such file or directory
    
    zimbra@mail:~/lib/ext$ ls
    clamscanner		  nginx-lookup		   zimbraldaputils
    com_zimbra_bulkprovision  zextras
    com_zimbra_cert_manager   zimbraadminversioncheck
    Still stumped, but thanks for the suggestions.

Similar Threads

  1. XMPP not working right...
    By Eclipse in forum Administrators
    Replies: 5
    Last Post: 08-24-2011, 01:24 PM
  2. Set XMPP priority
    By gmichels in forum Administrators
    Replies: 0
    Last Post: 02-25-2011, 09:59 AM
  3. Xmpp
    By rguembes in forum Administrators
    Replies: 7
    Last Post: 08-11-2010, 10:31 PM
  4. xmpp ssl errors
    By rhys_rhaven in forum Administrators
    Replies: 0
    Last Post: 05-05-2010, 04:13 PM
  5. Xmpp
    By Rom in forum Users
    Replies: 0
    Last Post: 04-19-2009, 06:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •