Results 1 to 3 of 3

Thread: All mail deferred on reboot but works again after zmcontrol stop/start on 6.0.5

  1. #1
    Join Date
    Feb 2010
    Location
    Auckland, NZ
    Posts
    47
    Rep Power
    5

    Default All mail deferred on reboot but works again after zmcontrol stop/start on 6.0.5

    Hi all. I have Zimbra 6.0.5_GA_2213 on Ubuntu 8.04.4. After some time of constant running I had to reboot the server. I did this by issuing "poweroff" under sudo and then repowered the server and it rebooted. Zimbra seemed to start ok except all incoming mail was being deferred. With "su zimbra" I did a "zmcontrol status" and everything was running except the last in the list "stats" which showed "stopped".

    I then did a "zmcontrol stop" and then "zmcontrol start". All services showed "Done" as well as stats. The system then delivered the mail in the deferred section and was delivering incoming mail ok.

    Can anyone help with why a reboot deffers all mail but a zmcontrol stop/start works ok? Is it a permission issue when the system boots?

    Cheers
    Andy

  2. #2
    Join Date
    Feb 2010
    Location
    Auckland, NZ
    Posts
    47
    Rep Power
    5

    Default

    I did a bit more investigation of the logs for both a reboot and a restart of Zimbra and there is a difference in the postscript section of the start up as below. "postfix/smtpd' is shown on a reboot but "postfix/postfix-script" is shown on a restart.

    I checked the bootup actions under webmin and the system runs a script to load postscript called "postfix". Should this run or does zimbra run its own postfix startup?



    Here is the section from the log for a reboot:

    Jul 5 15:39:10 ZIMBRA1 zmmailboxdmgr[13861]: status requested
    Jul 5 15:39:10 ZIMBRA1 zmmailboxdmgr[13861]: status OK
    Jul 5 15:39:12 ZIMBRA1 postfix/smtpd[13848]: warning: 112.78.3.130: address not listed for hostname vps130.vdrs.net
    Jul 5 15:39:13 ZIMBRA1 postfix/smtpd[13848]: connect from unknown[112.78.3.130]
    Jul 5 15:39:13 ZIMBRA1 postfix/smtpd[13848]: setting up TLS connection from unknown[112.78.3.130]
    Jul 5 15:39:14 ZIMBRA1 postfix/smtpd[13848]: Anonymous TLS connection established from unknown[112.78.3.130]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Jul 5 15:39:14 ZIMBRA1 postfix/smtpd[13800]: connect from unknown[213.87.240.33]
    Jul 5 15:39:16 ZIMBRA1 postfix/smtpd[13848]: 31E2C2320BB: client=unknown[112.78.3.130]
    Jul 5 15:39:16 ZIMBRA1 postfix/smtpd[13800]: C672B2320BD: client=unknown[213.87.240.33]
    Jul 5 15:39:17 ZIMBRA1 postfix/cleanup[14045]: 31E2C2320BB: message-id=<43B1D86622A9D1162B88A8E4D01959C5@bvp>
    Jul 5 15:39:17 ZIMBRA1 postfix/qmgr[4644]: 31E2C2320BB: from=<bh@intimexco.com>, size=1334, nrcpt=2 (queue active)
    Jul 5 15:39:17 ZIMBRA1 postfix/qmgr[4644]: warning: connect to transport private/smtp-amavis: Connection refused
    Jul 5 15:39:17 ZIMBRA1 postfix/error[14094]: 31E2C2320BB: to=<*.*.*@gmail.com>, orig_to=<info@tagnz.co.nz>, relay=none, delay=1.8, delays=1.7/0.05/0/0.06, dsn=4.3.0, status=deferred (mail
    transport unavailable)

    Here is the same section after a restart:

    Jul 5 15:46:49 ZIMBRA1 zmmailboxdmgr[25174]: status requested
    Jul 5 15:46:49 ZIMBRA1 zmmailboxdmgr[25174]: status OK
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25720]: warning: not owned by root: /opt/zimbra/data/postfix/spool
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25728]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/main.cf
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25729]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/master.cf
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25730]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/master.cf.in
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25733]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/etc
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25734]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/etc/hosts
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25735]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/etc/services
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25736]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/etc/nsswitch.conf
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25737]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/etc/resolv.conf
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25738]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/etc/localtime
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25739]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/usr
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25740]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/usr/lib
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25741]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/usr/lib/zoneinfo
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25742]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/usr/lib/zoneinfo/localtime
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25743]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/inet.submission
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25744]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25745]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_nisplus-2.7.so
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25746]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_dns.so.2
    Jul 5 15:47:05 ZIMBRA1 postfix/postfix-script[25747]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_files-2.7.so
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25748]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_dns-2.7.so
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25749]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_hesiod.so.2
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25750]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_hesiod-2.7.so
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25751]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_compat-2.7.so
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25752]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_nisplus.so.2
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25753]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_files.so.2
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25754]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_compat.so.2
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25755]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_nis-2.7.so
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25756]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/lib/libnss_nis.so.2
    Jul 5 15:47:06 ZIMBRA1 postfix/postfix-script[25789]: starting the Postfix mail system
    Jul 5 15:47:06 ZIMBRA1 postfix/master[25790]: daemon started -- version 2.6.5, configuration /opt/zimbra/postfix-2.6.5.2z/conf
    Jul 5 15:47:06 ZIMBRA1 postfix/qmgr[25795]: 965A52320CB: from=<*.*@gmail.com>, size=2427, nrcpt=2 (queue active)
    Jul 5 15:47:06 ZIMBRA1 postfix/qmgr[25795]: 785602320C4: from=<zimbra@*.co.nz>, size=434, nrcpt=3 (queue active)
    Jul 5 15:47:06 ZIMBRA1 postfix/qmgr[25795]: E898F2320C7: from=<zimbra@*.co.nz>, size=434, nrcpt=3 (queue active)
    Jul 5 15:47:06 ZIMBRA1 postfix/qmgr[25795]: 31E2C2320BB: from=<bh@intimexco.com>, size=1334, nrcpt=2 (queue active)
    Jul 5 15:47:06 ZIMBRA1 postfix/qmgr[25795]: 26D0B2320C8: from=<zimbra@*.co.nz>, size=432, nrcpt=3 (queue active)
    Jul 5 15:47:06 ZIMBRA1 postfix/qmgr[25795]: 435922320CA: from=<zimbra@*.co.nz>, size=443, nrcpt=3 (queue active)
    Jul 5 15:47:06 ZIMBRA1 postfix/qmgr[25795]: C9CA32320C1: from=<zimbra@*.co.nz>, size=432, nrcpt=3 (queue active)
    Jul 5 15:47:06 ZIMBRA1 postfix/qmgr[25795]: C672B2320BD: from=<JaniyaHarl@ebay.com>, size=5017, nrcpt=2 (queue active)
    Jul 5 15:47:06 ZIMBRA1 saslauthd[25799]: detach_tty : master pid is: 25799
    Jul 5 15:47:06 ZIMBRA1 saslauthd[25799]: ipc_init : listening on socket: /opt/zimbra/cyrus-sasl-2.1.23.3z/state/mux
    Jul 5 15:47:06 ZIMBRA1 zimbramon[17839]: 17839:info: Starting stats via zmcontrol
    Last edited by andynz; 07-05-2012 at 02:43 PM.

  3. #3
    Join Date
    Feb 2010
    Location
    Auckland, NZ
    Posts
    47
    Rep Power
    5

    Default

    Ok. Found the problem. There was an instance of postfix running at bootup which was conflicting with Zimbra postfix. I disabled it in Webmin. Must have been when I added a send email application some time ago. Anyway, Zimbra now boots correctly from power on.

    Not sure how to make threads as solved but this one is solved.

    Andy

Similar Threads

  1. Replies: 4
    Last Post: 04-01-2013, 06:34 AM
  2. Replies: 1
    Last Post: 09-19-2010, 10:55 PM
  3. Replies: 3
    Last Post: 05-22-2009, 03:16 PM
  4. zmcontrol start/stop suggestion
    By PhishKiller in forum Developers
    Replies: 3
    Last Post: 12-17-2007, 11:47 AM
  5. Unable to Stop/Start Zimbra without server reboot
    By swan801 in forum Installation
    Replies: 6
    Last Post: 09-04-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •