Results 1 to 1 of 1

Thread: Possible bug with zmrestoreldap Zimbra 7.2.0 (Network Edition)

  1. #1
    Join Date
    Jan 2011
    Posts
    12
    Rep Power
    4

    Exclamation Possible bug with zmrestoreldap Zimbra 7.2.0 (Network Edition)

    Hi all

    I'm putting an intial posting in hear as this is where it appears most previous posts about zmrestoreldap have appeard so hope it is right. The issue relates to what I think may be a bug in the script zmrestoreldap discovered during a restore of data.

    The background to the cause of the restore can be found in the users forum [link].
    Following this issue and some further work we settled on a possible corrupt install of Zimbra from the previous upgrade (7.1.2-7.1.3, then to 7.20).

    We opted to do a fresh install on the same hardware of both the OS (Ubuntu10.04 LTS) and the Zimbra and used the wiki on the network edition Disaster recovery as the main guide. A full backup was taken onto a remote device (via local mount) along with copies of OS config files (e.g. bind, resolv.conf, interfaces, hosts, e.t.c.)

    when we reached the point of running the command zmrestoreldap it kept failing with "ERROR: Failed to stop ldap", the DR guide advise that ldap should not be running however we tried with both ldap running and not running several times and also tried redoing the install from scratch again.

    Looking through the logs, there seemed to be an issue locating ldap so I edited zmrestoreldap and included the full path to the ldap script (opt/zimbra/bin), when I then tried zmrestoreldap it worked, and the ldap restore the worked.

    However given that we were in a time pressured environment I was not sure if there could be any other reason for this not working so before submitting the bug wanted to see what other people felt, and also have a forum post in case anyone else is trying to get this to work.

    My modified ldap file is attached, I made the changes in two places which shown below.

    sub fullLdapRestore {
    my ($configdb,$maindb) = @_;
    print "Stopping ldap...";
    my $rc = 0xffff & system("/opt/zimbra/bin/ldap stop");
    if ($rc != 0) {
    print "ERROR: failed to stop ldap.\n";
    exit 1;
    }
    print "done.\n";

    and

    restoreLdapConfig($configdb);
    restoreLdap($maindb);

    print "Starting ldap...";
    $rc = 0xffff & system("/opt/zimbra/bin/ldap start");
    if ($rc != 0) {
    print "ERROR: failed to start ldap.\n";
    exit 1;
    }
    print "done.\n";
    }

    Many thanks

    Tony
    Zimbra 7.2.0_GA_2669 (build 20120410002323) on Ubuntu 10.04 LTS (64Bit)
    Attached Files Attached Files

Similar Threads

  1. Replies: 2
    Last Post: 08-04-2010, 09:40 AM
  2. Replies: 7
    Last Post: 10-11-2009, 04:58 AM
  3. Replies: 0
    Last Post: 09-23-2009, 12:29 AM
  4. Zimbra Network Edition and Free Edition
    By overflow in forum Installation
    Replies: 2
    Last Post: 03-25-2009, 10:42 AM
  5. Replies: 1
    Last Post: 12-19-2006, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •