Hi all, (ZCS 7.2.0)
I've been having problem with my connection/server load.
Almost no mail goes out, all bounce back with 'Connection timeout' or 'Connection refused'
Upon closer inspection and head scratching, cursing at the upstream provider, etc. (The usual geek tantrums.), I've found that it seems Zimbra is not using the correct MX record to send out to.
This server has public static IP with reverse DNS, I've tried with/without split-DNS, different DNS namservers, all stays teh same.
I've tried to 'untick/tick' (turn it off and on again) the Use DNS option in ZCS web. Rebooted, etc. etc.

See what I mean below, in the logs, it shows trying to speak to intekom.co.za at but if I do a dig, the MX is supposed to be

Any help how I can fix this? (I've tried to re-queue all messages in defereed queue, but they just pop right back)

Jul 10 16:31:17 mail postfix/error[16818]: 2FD465CC0113: to=<tar@intekom.co.za>, relay=none, delay=0.29, delays=0.16/0.04/0/0.09, dsn=4.4.1, status=deferred (delivery mporarily suspended: connect to intekom.co.za[]:25: Connection refused)
[root@mail ~]# dig intekom.co.za mx

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-20.P1.el5 <<>> intekom.co.za mx
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18034
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;intekom.co.za.                 IN      MX

intekom.co.za.          654     IN      MX      20 mail.intekom.com.

mail.intekom.com.       401     IN      A

;; Query time: 58 msec
;; WHEN: Tue Jul 10 16:31:32 2012
;; MSG SIZE  rcvd: 79