Results 1 to 3 of 3

Thread: MySQL is trying to open a table handle but the .ibd file does not exist

  1. #1
    Join Date
    Jan 2008
    Rep Power

    Unhappy MySQL is trying to open a table handle but the .ibd file does not exist

    Hi everybody

    So I have a problem with the mysql database of zimbra because our hoster had a server crash. I see the following error in the mysql log file:

    120710 18:11:54  InnoDB: error: space object of table'mboxgroup57/imap_folder',
    InnoDB: space id 2192 did not exist in memory. Retrying an open.
    InnoDB: Error: space id in fsp header 1326254643, but in the page header 926233168
    120710 18:11:54  InnoDB: Error: tablespace id and flags in file './mboxgroup57/imap_folder.ibd' are 18446744073709551615 and 1800941417, but in the InnoDB
    InnoDB: data dictionary they are 2192 and 0.
    InnoDB: Have you moved InnoDB .ibd files around without using the
    InnoDB: Please refer to
    InnoDB: for how to resolve the issue.
    120710 18:15:39 [ERROR] /opt/zimbra/mysql/libexec/mysqld: Incorrect information in file: './mboxgroup57/imap_folder.frm'
    120710 18:19:44  InnoDB: cannot calculate statistics for table mboxgroup45/appointment
    InnoDB: because the .ibd file is missing.  For help, please refer to
    120710 18:19:44 [ERROR] MySQL is trying to open a table handle but the .ibd file for
    table mboxgroup45/appointment does not exist.
    Have you deleted the .ibd file from the database directory under
    the MySQL datadir, or have you used DISCARD TABLESPACE?
    how you can resolve the problem.
    It seems that 2 tables are affected. The mysql database is still working but it crashes often when users are working. I have visited the pages that the log sais but the information there, especially

    Create a matching .frm file in some other database directory and copy it to the database directory where the orphan table is located.

    Issue DROP TABLE for the original table. That should successfully drop the table and InnoDB should print a warning to the error log that the .ibd file was missing.
    is not sufficient for me. I don't know how to create a .frm file in another db directory. I barely have a clue about mysql. When I try
    /opt/zimbra/mysql/bin/mysqlcheck -c --databases mboxgroup57 mboxgroup45 --socket /opt/zimbra/db/mysql.sock
    it sais I need to use the option password, which is ironic because I don't know the zimbra password and the root user doesn't have access to the db. What can I do? I'm really lost here especially because it is a productive server with many users and my time windows I get to work on the problem are always limited. I haven't tried the disaster recovery described in the wiki because 1) I don't know for which versions it acually works 2) I'm afraid nothing will work afterwards.

    Thank you so so much in advance for helping me. If you need any information just tell me and I'll try to get it.


  2. #2
    Join Date
    Jan 2008
    Rep Power


    I solved the problem by reinstalling the server from scratch. I made a ticket in the zimbra support portal. They said that the MySQL Database seems to be corrupt. Instead of dumping and trying to recover the db (since I already have tried so many things) I just started getting the latest backup and setup the server again. In other words I couldn't solve the problem.


  3. #3
    Join Date
    Sep 2008
    Rep Power



    i had already a similar trouble with zimbra. My mysql database was crashed.
    The mailstore was full ok,

    but i was unable to restore the complete database with zimbra support.
    In the end the server cleaned up about 20GB of email out of mailstore.

    i can only recommend everybody to save the mysqldatabase separatly,

    zmlocalconfig -e mysql_backup_retention=3
    or via
    /opt/zimbra/mysql/bin/mysqldump --user=root --password=$mysql_root_password --socket=$mysql_socket \
    --all-databases --single-transaction --flush-logs > {dump-file}.sql

    best regards
    Last edited by stegbth; 07-13-2012 at 10:50 AM. Reason: link to url
    zmcontrol -v
    1x Release 6.0.10_GA_2692.UBUNTU8_64 NETWORK edition.
    1x Release 6.0.14_GA_2928.UBUNTU8_64 NETWORK edition
    2x Release 7.1.3_GA_3346.UBUNTU10_64 NETWORK edition, Patch 7.1.3_P1
    1x Release 8.0.2.GA.5569.UBUNTU12.64 NETWORK edition

    2x Release 6.0.10_GA_2692.UBUNTU8_64 FOSS edition
    2x Release 7.2.2_GA_2852.UBUNTU10_64 FOSS edition
    1x Release 7.1.4_GA_2555.UBUNTU10_64 FOSS
    1x Release 8.0.3.GA.5664.UBUNTU12.64 FOSS edition

Similar Threads

  1. Corrupt database? Table mboxgroupXX.revision doesn't exist
    By loginrl103 in forum Administrators
    Replies: 4
    Last Post: 05-16-2012, 06:08 AM
  2. Corrupt database? Table mboxgroupXX.revision doesn't exist
    By loginrl103 in forum Error Reports
    Replies: 0
    Last Post: 05-16-2012, 01:44 AM
  3. MySQL Table Upgrade - Is it necessary?
    By jv494 in forum Administrators
    Replies: 6
    Last Post: 02-23-2012, 11:46 PM
  4. Problem with MYSQL " doesn't exist
    By kaltera in forum Installation
    Replies: 4
    Last Post: 06-04-2010, 12:58 PM
  5. mysql mta table crashes often
    By kabal in forum Administrators
    Replies: 4
    Last Post: 10-16-2008, 04:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts