Results 1 to 2 of 2

Thread: TLS Password question

  1. #1
    Join Date
    Oct 2006
    Rep Power

    Exclamation TLS Password question

    Hey everyone,

    I'm using Version 4.0.2_GA_362.DEBIAN3.1 on Ubuntu 6.06.1 LTS
    The server is a 2.8 GHz P4 w/1MB cache and HT on, with 1536 MB of DDR2 and two 250 GB SATA drives in RAID1. The user load is about 40 and performance is good. For the most part everything is running very well with exception of the following issues, the first of which is related to TLS. (I should also mention I have ran zmfixperms, and all the permissions on files look to be correct).

    Issue #1.
    I was having an issue where I could not connect for SMTP using TLS, after looking in the logs, I realized there was no smtp.cert. I rebuilt all my certs, and now I can connect using TLS; however, my password never seems to work. The following is an example of trying to connect to via SMTP to Zimbra using TLS from my a workstation using Evolution (I have also tried it with Thunderbird with the same result)

    Dec 5 13:41:40 localhost postfix/smtpd[26353]: setting up TLS connection from unknown[192.168.X.XX]
    Dec 5 13:41:40 localhost postfix/smtpd[26353]: TLS connection established from unknown[192.168.X.XX]: TLSv1 with cipher RC4-MD5 (128/128 bits)
    Dec 5 13:41:47 localhost postfix/smtpd[26353]: warning: unknown[192.168.X.XX]: SASL LOGIN authentication failed
    Dec 5 13:41:56 localhost last message repeated 3 times
    Dec 5 13:41:58 localhost postfix/smtpd[26353]: disconnect from unknown[192.168.X.XX]
    Issue #2.

    External SMTP
    The server, for the short term, as been having all its mail relayed to it via the primary mail server, the primary mail server is also set as the relayhost and DNS looks are diabled on the Zimbra server. I am having a problem where users (and the other mail server) on the LAN can connect to Zimbra via SMTP; however, I try to connect from the internet I get nothing. The firewall as the correct ports open and if I do a port scan I find port 25 is open. I would like to note IMAP is working from the outside. I need to resolve this issue before I depreciate the old mail server. Could this be caused by the new server not having a MX record or having a relay host?

    Issue #3. This one is minor.

    When zmgengraphs runs I get the following error:

    DBD::mysql::st execute failed: Can't open file: 'disk_aggregate.MYI' (errno: 145) at ./zmgengraphs line 153.
    Error executing select distinct(host) from disk_aggregate with
    Can't open file: 'disk_aggregate.MYI' (errno: 145)
    Can't open file: 'disk_aggregate.MYI' (errno: 145) at ./zmgengraphs line 154.

    Can't call method "fetchall_arrayref" on an undefined value at ./zmgengraphs line 217.
    I have checked the permissions of disk_aggregate.MYI and it matches the other MYI files in that directory. Also, the graph generation appears to be working with exepction of a some volumes missing from the Disk stats, which seems logical given the error. I would like to note, as per directed on the wiki, I added the following lone to zmgengraphs (before which it did not operate).
    use lib '/opt/zimbra/zimbramon/lib/i386-linux-thread-multi';
    I look forward to hearing your responses and moving my zimbra box into production. Thanks in advance for you assistance.
    Last edited by 3RiversTechAdmin; 12-05-2006 at 12:38 PM. Reason: typos

  2. #2
    Join Date
    Oct 2006
    Rep Power

    Unhappy Anyone? please

    Anyone have any ideas on any of the issues? Thanks

Similar Threads

  1. External MTA and TLS Question
    By 3RiversTechAdmin in forum Administrators
    Replies: 5
    Last Post: 12-20-2006, 09:36 AM
  2. FC4 Test install getting SU: Incorrect Password
    By bbepristis in forum Installation
    Replies: 16
    Last Post: 08-11-2006, 10:07 AM
  3. User Migration / Account / Password Question
    By nexus in forum Installation
    Replies: 1
    Last Post: 07-28-2006, 09:02 PM
  4. Supporting SPA and TLS for SMTP relaying
    By pbwebguy in forum Installation
    Replies: 1
    Last Post: 05-18-2006, 07:59 AM
  5. tls auth only?
    By rmvg in forum Administrators
    Replies: 16
    Last Post: 10-23-2005, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts