Hi,

Our Zimbra platform worked well until a few days ago when all the message stop being delivered to the mailboxes to be added to the deferred queue.

Here is the error message I got :
Code:
status=deferred (conversation with mail.mydomain.com[xxx.xxx.xxx.xxx] timed out while sending end of data -- message may be sent more than once)
I read different post in the forum where issues seems to be the same as mine, but I was not able to figure out my issue with the answer to those post.

I checked with the "Incoming Mail Problems" wiki but it didn't solved the issue.

Here are some command result for troubleshooting :

host `hostname`
Code:
mydomain.com has address 192.168.xxx.xxx
mydomain.com mail is handled by 10 mydomain.com.
/etc/hosts
Code:
127.0.0.1   localhost.localdomain   localhost
192.168.xxx.xxx  mydomain.com clamtc02
#192.168.xxx.xxx clamtc02.mydomain.com clamtc02

172.26.252.xxx   nlasav02    nlasav02.mydomain.com
172.26.252.yyy   nlasav04    nlasav04.mydomain.com
172.26.252.zzz   nlasav05    nlasav05.mydomain.com
172.16.xxx.xxx   nvasav01    nvasav01.mydomain.com
172.16.yyy.yyy   nvasav03     nvasav03.mydomain.com
cat /etc/resolv.conf
Code:
search  internal_domain.com
nameserver 172.26.xxx.xxx
nameserver 172.26.xxx.xxx
dig mydomain.com MX
Code:
; <<>> DiG 9.3.4-P1 <<>> mydomain.com MX
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56947
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomain.com.         IN      MX

;; ANSWER SECTION:
mydomain.com.  6718    IN      MX      10 smtp2.mydomain.com.
mydomain.com.  6718    IN      MX      10 smtp.mydomain.com.

;; Query time: 338 msec
;; SERVER: 172.26.xxx.xxx#53(172.26.xxx.xxx)
;; WHEN: Mon Jul 16 18:56:39 2012
;; MSG SIZE  rcvd: 82
dig mydomain.com any
Code:
; <<>> DiG 9.3.4-P1 <<>> mydomain.com any
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36709
;; flags: qr rd ra; QUERY: 1, ANSWER: 8, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomain.com.         IN      ANY

;; ANSWER SECTION:
mydomain.com.  21600   IN      A       212.53.xxx.xxx
mydomain.com.  21600   IN      SOA     ns1.netnames.net. hostmaster.netnames.net. 2012012416 166066 83033 1162462 515586
mydomain.com.  21600   IN      NS      ns2.netnames.net.
mydomain.com.  21600   IN      NS      ns6.netnames.net.
mydomain.com.  21600   IN      NS      ns5.netnames.net.
mydomain.com.  21600   IN      NS      ns1.netnames.net.
mydomain.com.  21600   IN      MX      10 smtp.mydomain.com.
mydomain.com.  21600   IN      MX      10 smtp2.mydomain.com.

;; Query time: 58 msec
;; SERVER: 172.26.xxx.xxx#53(172.26.xxx.xxx)
;; WHEN: Mon Jul 16 19:01:01 2012
;; MSG SIZE  rcvd: 229
Here are other settings changes we tried :
  • Increase / Decrease the MTU
  • I increased the lmtp_destination_concurrency_limit (from 20 to 40)


One last information :
I am not able to telnet mydomain.com 10025
I am able to telnet localhost 10025

So here I am, with no other solution to investigate.

Does anyone has a clue for me ???