Results 1 to 4 of 4

Thread: [SOLVED] Since update from 3.1.4 to 4.0.4, having problems.

  1. #1
    Join Date
    Mar 2006
    Rep Power

    Default [SOLVED] Since update from 3.1.4 to 4.0.4, having problems.


    I upgraded from 3.1.4 to 4.0.4 on a debian sarge server . Upgrade went fine and server worked perfectly right after it.

    A few days later, some of my users started to have problems. They could still send emails from there mail client but none would come in.

    I checked in the admin console and found that all of there emails were in the deffered queue and even if I requeued them, they would return to the deffered queue.

    To test, i recreated their account and emails started to work normally again for them until the next day.

    On that day, some of the users that had problems the day before started to have the same problems again, but new ones started to have that problem to. Same problem, able to send emails from mail client but all incoming emails would be stuck in the deffered queue.

    I tried there account in the zimbra webmail interface and found out that I could not send emails from there.

    I receaved the message : A network error has occured.

    And here is the complete error it gave me :

    msg - system failure: indexMessage caught IOException
    com.zimbra.cs.service.ServiceException: system failure: indexMessage caught IOException
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser
    at com.zimbra.cs.index.Indexer.indexMessage(Indexer.j ava:161)
    at com.zimbra.cs.mailbox.Message.reindex( :421)
    at com.zimbra.cs.mailbox.Mailbox.endTransaction(Mailb
    at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(M
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:3062)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:3034)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M
    at com.zimbra.cs.operation.SendMsgOperation.callback(
    at com.zimbra.cs.operation.Operation.schedule(Operati
    at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:109)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:162)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at ternalDoFilter(
    at Filter(
    at org.apache.catalina.core.StandardWrapperValve.invo ke(
    at org.apache.catalina.core.StandardContextValve.invo ke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke (
    at org.apache.catalina.core.StandardEngineValve.invok e(
    at org.apache.catalina.valves.AccessLogValve.invoke(A
    at org.apache.catalina.connector.CoyoteAdapter.servic e(
    at org.apache.coyote.http11.Http11Processor.process(H
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt
    at Socket(
    at ead.runIt(
    at org.apache.tomcat.util.threads.ThreadPool$ControlR
    Caused by: Could not create index /opt/zimbra/index/0/9/index/0 (directory already exists)
    at com.zimbra.cs.index.MailboxIndex.openIndexWriter(M
    at com.zimbra.cs.index.MailboxIndex.addDocument(Mailb
    at com.zimbra.cs.index.Indexer.addDocument(Indexer.ja va:354)
    at com.zimbra.cs.index.Indexer.addDocument(Indexer.ja va:324)
    at com.zimbra.cs.index.Indexer.indexMessage(Indexer.j ava:156)
    ... 32 more
    Caused by: Lock obtain timed out: Lock@/opt/zimbra/apache-tomcat-5.5.1...173-write.lock
    at org.apache.lucene.index.IndexWriter.<init>(IndexWr
    at org.apache.lucene.index.IndexWriter.<init>(IndexWr
    at com.zimbra.cs.index.MailboxIndex.openIndexWriter(M
    ... 36 more

    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver

    Has any one experienced this?

    Like I said, if a recreate those accounts, it works again normally but the issue eventually resurfaces.


  2. #2
    Join Date
    Aug 2005
    San Mateo, CA
    Rep Power


    Looks like some indexing problems. Any disk failure or are you using some sort of NFS filesystem? Did you try to just re-index the problem accounts via the admin console?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Mar 2006
    Rep Power


    Thanx Kevin for answering,

    By looking at the server, there does not appear to be any disk failure and I do not use any NFS disk for my server.

    I did not try the reindex options because I was not aware of it but I will certainly try it.

    I will keep you posted with my results.

    Thanx for your help

  4. #4
    Join Date
    Aug 2005
    Rep Power

Similar Threads

  1. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM
  2. Upgrade from 3.1.4 -> 4.0.4 on CentOS4.3... Success!
    By jeg1972 in forum Administrators
    Replies: 2
    Last Post: 12-20-2006, 10:28 PM
  3. Problems from 3.1.4 to 4.0.1
    By chaas in forum Installation
    Replies: 2
    Last Post: 09-13-2006, 09:15 AM
  4. 3.1.4 Update - FC3
    By tbullock in forum Administrators
    Replies: 3
    Last Post: 07-27-2006, 10:29 PM
  5. After upgrade to 3.1.4, problems...
    By pcjackson in forum Administrators
    Replies: 4
    Last Post: 06-29-2006, 05:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts