Hello,

a potential customer has tried to e-mail us, and has been complaining that their e-mail is "bounced"..

Here is a snippet of the logs showing the problem


Aug 24 03:03:57 mail postfix/smtpd[17073]: NOQUEUE: reject: RCPT from unknown[72.52.99.152]: 450 4.7.1 Client host rejected: cannot find your
hostname, [72.52.99.152]; from=<xxxx@mac.com> to=<xxxx@ourdomain.com> proto=ESMTP helo=<milan.hostgo.com>

milan.hostgo.com has not been obfuscated, that is what's being sent as the helo


I have the following enabled:

Global Settings > MTA > Protocol Checks

Hostname in greeting violateds RFC (reject_invalid_hostname)

Client must greet with a fully qualified hostname (reject non_fqdn hostname)
(this one would be the one to uncheck to allow mail in this situation - correct?)

Sender address must be fully qualified (reject_non-fqdn_sender)

Global Settings > MTA > DNS Checks

Client's IP Address (reject_unknown_client)

Hostname in greeting (reject unknown hostname)

Sender's Domain (reject_unknown_sender_domain)

Question:
Is it possible to allow mail from this one mail server (milan.hostgo.com) or (hostgo.com) to bypass the protocol and dns checks?
If so, how would I go about implementing this?

Thank you very much

Bill

Release 7.1.1_GA_3196.RHEL5_64_20110527011124 CentOS5_64 FOSS edition.