Results 1 to 8 of 8

Thread: Cannot send mail after upgrade from 7.2.1. to 8 (ose)

Hybrid View

  1. #1
    Join Date
    Mar 2012
    Posts
    6
    Rep Power
    3

    Wink [SOLVED ?] Cannot send mail after upgrade from 7.2.1. to 8 (ose)

    Hi All,

    =====
    I kind of solved the problem below by:

    - unchecking the milter server in the MTA settings pages in the admin console.
    - removing the milter server name (was pointing to my own mailserver name.
    - restarting. I can send mail again.

    Then I experimented a bit:

    - rechecking the milter server and restarting zimbra: I can still send mail.
    - setting the milter server name to "localhost" and restarting: Still able to send mail.
    - setting the milter server name to my email server fqdn hostname: Not able to send mail.
    - setting the milter server name back to localhost: Can send mail again!

    So it seems that using my fqdn server name is the source of the problem. I am still not shure of why this can be.

    =====

    A few days ago I upgraded my Zimbra 7.2.1. Open Source Edition to Zimbra 8 (O.S.E.). Zimbra is running on Ubuntu 10.04 LTS.
    I had no problems whatsoever with running 7.2.1.

    I'm not running split DNS, but I do use a relay host for all outbound emails using smtp authentication. I did a renewed setup of that after the upgrade to zimbra 8.

    Since the upgrade I cannot send email. Receiving works ok. After some searching in the mail.log file I found the following error:

    Sep 18 20:23:14 email postfix/smtpd[13609]: connect from email.xxxxxxxx.xx[999.999.999.999]
    Sep 18 20:23:14 email postfix/smtpd[13609]: warning: connect to Milter service inet:localhost:8465: Connection refused
    Sep 18 20:23:14 email postfix/smtpd[13609]: NOQUEUE: milter-reject: CONNECT from email.xxxxxxxx.xx[999.999.999.999]: 451 4.7.1 Service unavailable - try again later; proto=SMTP
    Sep 18 20:23:14 email postfix/smtpd[13609]: NOQUEUE: milter-reject: EHLO from email.xxxxxxxx.xx[999.999.999.999]: 451 4.7.1 Service unavailable - try again later; proto=SMTP helo=<email.xxxxxxxx.xx>
    Sep 18 20:23:14 email postfix/smtpd[13609]: NOQUEUE: milter-reject: MAIL from email.xxxxxxxx.xx[999.999.999.999]: 451 4.7.1 Service unavailable - try again later; from=<henry@vorsterp.nl> proto=ESMTP helo=<email.xxxxxxxx.xx>
    Sep 18 20:23:14 email postfix/smtpd[13609]: disconnect from email.xxxxxxxx.xx[999.999.999.999]


    What struck me was that the milter service seems to be listening on port 8465. In my mta-settings on the admin console the bind port is 7026. The milter server checkbox is checked. Furthermore I found out that an opendkim process is listening to 8465. To be honest, I had no idea what that opendkim does or why I need it. But it seems to be conflicting with the milter settings in the admin console.

    I have tried the following:

    - unchecking the milter server checkbox and restarting zimbra. No effect.
    - Changing the milter server bind address to 8465, with the milter server checkbox on and off. No effect.

    The milter service is running (checked with zmmilterctl status).

    So now I am at a loss. Are there any setting that I have missed? Are there any changes I should make? Help is most welcome!

    Kind regards,

    Henry
    Last edited by henryvandevorst; 09-19-2012 at 06:34 AM.

  2. #2
    Join Date
    Oct 2009
    Posts
    147
    Rep Power
    6

    Default

    Maybe some more about your configuration.
    I too ran 7.2.1 and I upgraded to 8 and from ubuntu 10 to 12.
    No problem.
    Anyway, I do the split dns thing, know what I'm saying.
    I also have zimbra basically relay all emails outbound via smtp authenticated approach.
    So after every upgrade, I rerun my postfix and zmprov commands that setup my relay for outbound email.
    Inbound is all good.

    So you might want to say more I think that would help some of the more talented folks to chime in.
    I'm just a rookie on this allstar tema
    --
    3 out of 2 people have truble wit inglish and fraktions
    Intel Quad Core Xeon CPU 3.20GHz | 2 Gig RAM | Dual SCSI 73 Gig HDD
    Ubuntu Server 12.04.1 LTS 64 bit | Release 8.0.2_GA_5569 (build 20121210115059) UBUNTU12_64 FOSS

  3. #3
    Join Date
    Mar 2012
    Posts
    6
    Rep Power
    3

    Default

    Hi spectra,

    Thanks for your reply.
    As far as I know using an external email relay host is the only "special" thing I am doing. All other configuration is through the admin console. I have added this to the original post.
    What other configuration options would be of interest when trying to solve this?

    Best regards,

    Henry

  4. #4
    Join Date
    Aug 2012
    Location
    Germany
    Posts
    9
    Rep Power
    3

    Default

    Somehow, it seems that an initially post by henryandevorst is missing for me. But reading that there are problems in sending emails with an smtp relay, maybe this thread will help you too:
    http://www.zimbra.com/forums/install...ix-reload.html
    With ZCS 8 you have to edit the postfix values through the zmlocalconfig.

    If this was not the problem, I beg your pardon for "hijacking" the thread.

  5. #5
    Join Date
    Mar 2012
    Posts
    6
    Rep Power
    3

    Default

    Hi Thopu,

    Thanks for pointing me to this. Will try the suggestions in that thread.

    Don't know ik you still cannot see the original mail, but hee it is:

    =======

    Hi All,

    A few days ago I upgraded my Zimbra 7.2.1. Open Source Edition to Zimbra 8 (O.S.E.). Zimbra is running on Ubuntu 10.04 LTS.
    I had no problems whatsoever with running 7.2.1.

    I'm not running split DNS, but I do use a relay host for all outbound emails using smtp authentication. I did a renewed setup of that after the upgrade to zimbra 8.

    Since the upgrade I cannot send email. Receiving works ok. After some searching in the mail.log file I found the following error:

    Sep 18 20:23:14 email postfix/smtpd[13609]: connect from email.xxxxxxxx.xx[999.999.999.999]
    Sep 18 20:23:14 email postfix/smtpd[13609]: warning: connect to Milter service inet:localhost:8465: Connection refused
    Sep 18 20:23:14 email postfix/smtpd[13609]: NOQUEUE: milter-reject: CONNECT from email.xxxxxxxx.xx[999.999.999.999]: 451 4.7.1 Service unavailable - try again later; proto=SMTP
    Sep 18 20:23:14 email postfix/smtpd[13609]: NOQUEUE: milter-reject: EHLO from email.xxxxxxxx.xx[999.999.999.999]: 451 4.7.1 Service unavailable - try again later; proto=SMTP helo=
    Sep 18 20:23:14 email postfix/smtpd[13609]: NOQUEUE: milter-reject: MAIL from email.xxxxxxxx.xx[999.999.999.999]: 451 4.7.1 Service unavailable - try again later; from= proto=ESMTP helo=
    Sep 18 20:23:14 email postfix/smtpd[13609]: disconnect from email.xxxxxxxx.xx[999.999.999.999]


    What struck me was that the milter service seems to be listening on port 8465. In my mta-settings on the admin console the bind port is 7026. The milter server checkbox is checked. Furthermore I found out that an opendkim process is listening to 8465. To be honest, I had no idea what that opendkim does or why I need it. But it seems to be conflicting with the milter settings in the admin console.

    I have tried the following:

    - unchecking the milter server checkbox and restarting zimbra. No effect.
    - Changing the milter server bind address to 8465, with the milter server checkbox on and off. No effect.

    The milter service is running (checked with zmmilterctl status).

    So now I am at a loss. Are there any setting that I have missed? Are there any changes I should make? Help is most welcome!

    ==========

  6. #6
    Join Date
    Mar 2012
    Posts
    6
    Rep Power
    3

    Default

    Hi All,

    A short update. I followd Thopu's advice in pointing me to this thread: 8-0-0-main-cf-not-persistent-after-postfix-reload.html.
    That had no effect.

    After that I deleted the milter-server entry (it was pointing to my mailserver) and unchecked the milter server checkbox in the MTA settings in the admin console. I can send emails now, so my immediate problem is over.

    Furthermore I ca be sure now that my problems have something to do with the milter server settings. Any idea's?

  7. #7
    Join Date
    Mar 2012
    Location
    Poland
    Posts
    12
    Rep Power
    3

    Default

    Hi everybody,
    I think Your problems are related to adding built-in support for DKIM in Zimbra 8.0. After upgrading from previous version there is some options added to postfic main.cf (smtpd_milters = inet:localhost:8465 and non_smtpd_milters = inet:localhost:8465). Your previous settings are kept but when You were using external opendkim instance there is a conflict with one which is now built-in Zimbra 8.0. I encountered the same problems like You.
    Best solution in this case is not to fight the system, and let Zimbra manage Your DKIM keys (BTW it's feature I was waiting for).
    Steps to do:
    ---Before upgrading Zimbra to 8.0
    - uninstall opendkim (eg. apt-get remove opendkim)
    - remove milter settings from Zimbra configuration (do not edit main.cf file, it should be done by zimbra configuration commands)
    zmprov ms `zmhostname` zimbraMtaSmtpdMilters ""
    zmprov ms `zmhostname` zimbraMtaNonSmtpdMilters ""
    zmcontrol restart
    ---Now run install.sh to upgrade Zimbra
    after upgrading take a look on running services (ps aux | grep opendkim - you will see that there's opendkim running inside zimbra)
    look that milter configuration has changed (cat /opt/zimbra/postfix/conf/main.cf - there are two new values)
    ---Use this page to configure built-in DKIM feature - Configuring for DKIM Signing - Zimbra :: Wiki

Similar Threads

  1. Replies: 2
    Last Post: 06-06-2011, 12:56 AM
  2. [SOLVED] Upgrade to 6.0.9 - can't send mail
    By mingus8686 in forum Installation
    Replies: 0
    Last Post: 12-20-2010, 10:50 AM
  3. [SOLVED] Can't send mail after upgrade
    By bluenix in forum Installation
    Replies: 1
    Last Post: 10-06-2008, 07:52 AM
  4. Replies: 9
    Last Post: 01-26-2007, 06:31 AM
  5. Mail send problem after upgrade
    By cutigersfan in forum Administrators
    Replies: 2
    Last Post: 05-13-2006, 07:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •