Results 1 to 5 of 5

Thread: SMTP relay for another domain no longer works since I upgraded to 7.2.1

Threaded View

  1. #1
    Join Date
    Oct 2011
    Rep Power

    Default [SOLVED] SMTP relay for another domain no longer works since I upgraded to 7.2.1

    Hi all,

    well I upgrade my Zimbra server to 7.2.1 and it stopped relaying the mail from another server to the world (it still relays the mail to its own domain users)

    This is how I did it last year:
     Setting a relay host
    see also Sending mail through an external relay
    Set the relay host in the admin console, MTA tab to point to your ISPs outgoing mail server. Your ISP can tell you the proper value for this.
    You may have to set the port, as well. From the command line:
    zmprov ms zimbraMtaRelayHost
    Enabling SMTP authentication
    Create a text file mapping which name/password should be used for each given outbound destination:
    echo username:password > /opt/zimbra/conf/relay_password
    Create a postfix lookup table:
    postmap hash:/opt/zimbra/conf/relay_password
    To test that the lookup table is correct, the following should return username:password:
    postmap -q /opt/zimbra/conf/relay_password
    Configure postfix to use the new password map:
    postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password
    Configure postfix to use SSL authentication:
    postconf -e smtp_sasl_auth_enable=yes
    Configure postfix to use the outgoing servername rather than the canonical server name:
    postconf -e smtp_cname_overrides_servername=no
    smtp_cname_overrides_servername=no is used because many smtp servers forward the connection different server than the one set in the smtp_sasl_password_maps file.
    Example of the problem :
    /opt/zimbra/conf/relay_password :
    but postfix connects to
    Postfix will not send the authentication info contained in smtp_sasl_password_maps file because it as no entry for the server but has one for
    If you apply smtp_tls_per_site settings then smtp_cname_overrides_servername may become obsolete.
    Restart postfix:
    postfix reload
    Enable TLS
    As Zimbra user:
    postconf -e smtp_use_tls=yes
    postfix reload
    Its from this page: Outgoing SMTP Authentication - Zimbra :: Wiki

    Worked perfectly until last night (my upgrade to 7.2.1).

    Now every mail sent outside the smtp's domain I get this message: host[ipaddress] said: 554
    5.7.1 <>: Relay access denied (in reply to RCPT TO

    I googled this forum but I couldnt find anything.

    Anyone knows what I should do ?

    Can I downgrade to the previous version if there is no way to do it with 7.2.1 ?

    Thank you.
    Last edited by Wasowski; 09-22-2012 at 10:50 PM.

Similar Threads

  1. use another smtp relay for specific domain
    By sirio81 in forum Administrators
    Replies: 3
    Last Post: 08-06-2011, 01:54 AM
  2. smtp relay for external domain
    By djingo in forum Administrators
    Replies: 0
    Last Post: 06-24-2010, 07:47 AM
  3. Upgraded BES to and mail no longer syncing to Blackberry's
    By bfrederick in forum Zimbra Connector for BlackBerry
    Replies: 5
    Last Post: 06-01-2009, 06:58 AM
  4. Calendar no longer works
    By davidfsmith in forum Zimbra Connector for BlackBerry
    Replies: 5
    Last Post: 01-18-2008, 04:05 AM
  5. Private key extraction no longer works
    By InternetGuy in forum Administrators
    Replies: 4
    Last Post: 01-11-2008, 11:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts