Results 1 to 2 of 2

Thread: Zimbra (7.2.1) + LDAP + Samba error creating domain - errors installing

  1. #1
    Join Date
    May 2011
    Rep Power

    Default Zimbra (7.2.1) + LDAP + Samba error creating domain - errors installing

    Hi, I've been trying to get zimbra to administer a samba domain, but all efforts have proved futile. I have zimbra 7.2.1, RHEL5_64 build. I'm basing my install on this doc and all the docs it references:

    UNIX_and_Windows_Accounts_in_Zimbra_LDAP_and_Zimbr a_Admin_UI

    First, I had errors adding to the schema. Essentially, I did as the doc said:

    ldap stop
    cp /opt/zimbra/openldap/etc/openldap/schema/nis.ldif /opt/zimbra/data/ldap/config/cn\=config/cn\=schema/cn\=\{10\}nis.ldif
    cd /opt/zimbra/data/ldap/config/cn\=config/cn=\schema
    changed the contents of the nis.ldif file to:

     dn: cn={10}nis
     objectClass: olcSchemaConfig
     cn: {10}nis
    then did:

    chmod 600 cn\=\{10\}nis.ldif
    ldap start
    Failed to start slapd.  Attempting debug start to determine error.
    505f4373 config error processing cn={10}nis,cn=schema,cn=config,cn=schema,cn=config:
    I solved that error using the following file and converting it to ldif format as described in the doc.

    I did the rest of the steps successfully, but when I start samba, right before step 4 the domain isn't added and the following error appears:

      smbldap_search_domain_info: Query was: dc=mail,dc=mailv2-0,dc=com, (&(objectClass=sambaDomain)(sambaDomainName=VERSION2.0))
    [2012/09/23 10:24:47.019174,  2] passdb/pdb_ldap.c:6621(pdb_init_ldapsam)
      pdb_init_ldapsam: WARNING: Could not get domain info, nor add one to the domain
    Any clues how I can fix this? I really have no clue what could be wrong. Is there any way to verify manually that the schema is correct?

    Thnx a million!

  2. #2
    Join Date
    May 2011
    Rep Power


    K so I got more of a clue but it still doesn't work. After increasing verbosity of ldap log, and looking at /var/log/zimbra.log I found the following error:

    hdb_dn2id: get failed: DB_NOTFOUND: No matching key/data pair found (-30988)
    access_allowed: disclose access to "dc=mydomain,dc=com" "entry" requested
    Someone somewhere suggested that it usually happens when an index was created not not indexed. So I tried to manually start indexing the entries required for zimbra_samba and zimbra_posix. I gave me an error:

    Effectively, I hadn't created the memberuid index. So I did and started up the manual indexing, and it finished without an error. I restarted ldap and still, samba cannot create a domain in the ldap directory. The error above persists.

Similar Threads

  1. Replies: 0
    Last Post: 09-26-2010, 11:48 PM
  2. Zimbra & Samba -- error joining machine to Domain
    By jmartin in forum Administrators
    Replies: 5
    Last Post: 01-09-2009, 03:28 AM
  3. Error creating Samba Domain
    By strikermdd in forum Administrators
    Replies: 1
    Last Post: 10-06-2008, 08:59 AM
  4. Replies: 8
    Last Post: 08-19-2008, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts