Results 1 to 3 of 3

Thread: Tried to "zmtlsctl redirect" but connection refused; Zimbra not listening on port 80

Hybrid View

  1. #1
    Join Date
    Sep 2012
    Posts
    2
    Rep Power
    3

    Default Tried to "zmtlsctl redirect" but connection refused; Zimbra not listening on port 80

    Hi all- we've got Zimbra 8.0.0 64 FOSS edition on Ubuntu 12.04.1 x64. Just wondering if anyone has seen this problem before? Zimbra is working fine via SSL on port 443. I also want to set up the redirect from port 80, so users won't have to type the https.

    I dutifully executed these commands from the zimbra user:

    Code:
    zmtlsctl redirect
    zmcontrol stop
    zmcontrol start
    But the redirect does not work; connections to port 80 are refused. Looking at netstat, I see that no one is listening on port 80:

    Code:
    $ sudo netstat -anltp | grep "LISTEN"
    tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN      12667/nginx.conf
    tcp        0      0 127.0.0.1:7171          0.0.0.0:*               LISTEN      11718/java
    tcp        0      0 0.0.0.0:7780            0.0.0.0:*               LISTEN      12818/httpd
    tcp        0      0 10.77.23.109:389        0.0.0.0:*               LISTEN      11392/slapd
    tcp        0      0 0.0.0.0:7110            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 0.0.0.0:7143            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 127.0.0.1:10024         0.0.0.0:*               LISTEN      12718/amavisd (mast
    tcp        0      0 127.0.0.1:10025         0.0.0.0:*               LISTEN      13138/master
    tcp        0      0 127.0.0.1:10026         0.0.0.0:*               LISTEN      12718/amavisd (mast
    tcp        0      0 127.0.0.1:7306          0.0.0.0:*               LISTEN      12563/mysqld
    tcp        0      0 0.0.0.0:587             0.0.0.0:*               LISTEN      13138/master
    tcp        0      0 0.0.0.0:11211           0.0.0.0:*               LISTEN      12640/memcached
    tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN      12667/nginx.conf
    tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      12667/nginx.conf
    tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 127.0.0.1:8465          0.0.0.0:*               LISTEN      13162/opendkim
    tcp        0      0 0.0.0.0:465             0.0.0.0:*               LISTEN      13138/master
    tcp        0      0 0.0.0.0:7025            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 10.77.23.109:53         0.0.0.0:*               LISTEN      704/named
    tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      704/named
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      588/sshd
    tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      13138/master
    tcp        0      0 0.0.0.0:7993            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN      704/named
    tcp        0      0 0.0.0.0:8443            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 0.0.0.0:7995            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      12667/nginx.conf
    tcp        0      0 0.0.0.0:7071            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 0.0.0.0:7072            0.0.0.0:*               LISTEN      12636/java
    tcp        0      0 0.0.0.0:993             0.0.0.0:*               LISTEN      12667/nginx.conf
    tcp6       0      0 :::11211                :::*                    LISTEN      12640/memcached
    tcp6       0      0 :::53                   :::*                    LISTEN      704/named
    tcp6       0      0 :::22                   :::*                    LISTEN      588/sshd
    tcp6       0      0 ::1:953                 :::*                    LISTEN      704/named
    I tried restarting the server, and restarting Zimbra again too. Also tried switching the mode to "http" and then back to "redirect", but still no effect: Zimbra isn't listening on port 80.

    Would love to get the redirect working, if someone could suggest some places to check. Thanks if you can help! I will provide any files, contents etc. that might assist.

  2. #2
    Join Date
    Sep 2012
    Posts
    2
    Rep Power
    3

    Default

    Ah, figured it out.

    I'll post this for anyone else who might be searching one day:

    During initial configuration, in the zimbra-proxy section I had chosen "Enable HTTP[S] Proxy". (I had misinterpreted it, and thought that option was necessary in order for the SSL version of IMAP and POP to be enabled.)

    I just re-installed without enabling the HTTP Proxy, and now all is well.

  3. #3
    Join Date
    Apr 2011
    Location
    Trento - Italy
    Posts
    13
    Rep Power
    4

    Default

    su zimbra -
    zmtlsctl both

Similar Threads

  1. "View Mail" from Admin console redirect to custom port
    By darius.ralys@artilux.lt in forum Installation
    Replies: 2
    Last Post: 10-20-2011, 11:15 PM
  2. Wrong Sorting/Listening in "Sent" Folder
    By yogg1 in forum Administrators
    Replies: 2
    Last Post: 09-27-2011, 12:23 AM
  3. zmtlsctl "redirect" mode still allowing non-SSL
    By mikelcu in forum Administrators
    Replies: 6
    Last Post: 08-04-2010, 05:26 PM
  4. Replies: 1
    Last Post: 04-21-2010, 06:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •