Results 1 to 6 of 6

Thread: Upgrade problem

Threaded View

  1. #1
    Join Date
    Dec 2006
    Location
    Switzerland
    Posts
    4
    Rep Power
    8

    Default Upgrade problem

    Hi,

    I'm trying to copy and upgrade our existing Zimbra installation 3.0.1_GA_160.FC4 to 4.0.4_GA_457.FC4. I transferred /opt/zimbra to the testserver with rsync (preserving perms). I changed hostname and hosts-entries to the same as on our existing Zimbra server. While starting Zimbra following error occured: /opt/zimbra/java/bin/java => permission denied.
    I tried to fix folder permissions with "zmfixperms" but without another result...the same error occured.
    Ignoring the error messages i started install.sh to upgrade Zimbra.
    The upgrade failed (who wonders ).
    I checked the install log (/tmp) :

    Code:
    COMMAND: zmlocalconfig -s | sed -e "s/ = \(.*\)/=\'\1\'/" > /opt/zimbra/.saveconfig/config.save
    COMMAND: zmcontrol shutdown
    Host host.domain.ch
    	Stopping mta...Done
    	Stopping spell...Done
    	Stopping snmp...Done
    	Stopping antivirus...Done
    	Stopping antispam...Done
    	Stopping imapproxy...Done
    	Stopping mailbox...Done
    	Stopping logger...Done
    	Stopping ldap...Done
    Preparing packages for installation...
    zimbra-core-4.0.4_GA_457.FC4-20061115174327
    ldconfig: /opt/zimbra/lib/libldap_r-2.2.so.7 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/libmysqlclient_r.so.14 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/liblber-2.2.so.7 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/libldap-2.2.so.7 is not a symbolic link
    
    mkdir: cannot create directory `/opt/zimbra/ssl': File exists
    mkdir: cannot create directory `/opt/zimbra/.ssh': File exists
    Loading classes to share ... done. 
    Rewriting and unlinking classes ... done. 
    Calculating hash values for String objects .. done. 
    Calculating fingerprints ... done. 
    Removing unshareable information ... done. 
    Moving most read-only objects to shared space at 0x90bb0000 ... done. 
    Moving common symbols to shared space at 0x90f2c4f0 ... done. 
    Moving remaining symbols to shared space at 0x91058280 ... done. 
    Moving string char arrays to shared space at 0x91058d10 ... done. 
    Moving additional symbols to shared space at 0x910da7b8 ... done. 
    Read-only space ends at 0x9112eaf8, 5761784 bytes.
    Moving read-write objects to shared space at 0x913b0000 ... done. 
    Moving String objects to shared space at 0x91939c50 ... done. 
    Read-write space ends at 0x91979d78, 6069624 bytes.
    Updating references to shared objects ... done. 
    
    Preparing packages for installation...
    zimbra-ldap-4.0.4_GA_457.FC4-20061115174327
    ldconfig: /opt/zimbra/lib/libldap_r-2.2.so.7 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/libmysqlclient_r.so.14 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/liblber-2.2.so.7 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/libldap-2.2.so.7 is not a symbolic link
    
    Preparing packages for installation...
    zimbra-logger-4.0.4_GA_457.FC4-20061115174327
    Preparing packages for installation...
    zimbra-mta-4.0.4_GA_457.FC4-20061115174327
    umount2: Invalid argument
    umount: /opt/zimbra/amavisd/tmp: not mounted
    mv: cannot stat `/opt/zimbra/amavisd': No such file or directory
    chown: changing ownership of `/opt/zimbra/httpd': No such file or directory
    chown: changing ownership of `/opt/zimbra/mysql': No such file or directory
    chown: changing ownership of `/opt/zimbra/snmp': No such file or directory
    ldconfig: /opt/zimbra/lib/libldap_r-2.2.so.7 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/libmysqlclient_r.so.14 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/liblber-2.2.so.7 is not a symbolic link
    
    ldconfig: /opt/zimbra/lib/libldap-2.2.so.7 is not a symbolic link
    
    Preparing packages for installation...
    zimbra-snmp-4.0.4_GA_457.FC4-20061115174327
    Preparing packages for installation...
    zimbra-store-4.0.4_GA_457.FC4-20061115174327
    Preparing packages for installation...
    zimbra-apache-4.0.4_GA_457.FC4-20061115174327
    Preparing packages for installation...
    zimbra-spell-4.0.4_GA_457.FC4-20061115174327
    COMMAND: zmlocalconfig -f -e ldap_cache_account_maxage='15'
    ........etc.....
    I recognized the different symbolic-links error messages and re-created the symbolic-links manually and re-run'd the install-script..but with the same error-outputs.

    Do you have an idea whats going wrong?

    Is that the right way to move and update zimbra? :
    - Stop Zimbra
    - Rsync Zimbra to the new server via SSH (preserving permissions)
    - Change host-name and /etc/hosts to match the existing Zimbra-Installation
    - Upgrade Zimbra with install.sh

    Thanks for any suggestions!
    (Sorry for my bad English )
    Last edited by NickB; 12-14-2006 at 08:19 AM.

Similar Threads

  1. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-29-2006, 12:36 AM
  2. 3.1.3OS Upgrade Problem
    By mcevoys in forum Installation
    Replies: 7
    Last Post: 06-16-2006, 10:47 AM
  3. 3.0.1 GA upgrade problem
    By kollross in forum Administrators
    Replies: 5
    Last Post: 04-04-2006, 11:42 AM
  4. Another odd GA upgrade problem (FYI)
    By meikka in forum Installation
    Replies: 0
    Last Post: 02-08-2006, 01:38 PM
  5. Odd GA upgrade problem
    By drewage in forum Installation
    Replies: 2
    Last Post: 02-08-2006, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •