Results 1 to 2 of 2

Thread: Crashed Server - Methods to Recover Data?

Hybrid View

  1. #1
    Join Date
    Jul 2007
    St. Louis, MO
    Rep Power

    Default Crashed Server - Methods to Recover Data?

    My server HDD failed. The server's filesystem is currently in a read-only state:

    OS: RHEL4.5
    ZCS: 4.5.11

    I had always used rsync to take "backups" of the /opt directory. I quote backups as I used that lightly being that I have now learned this is not an ideal backup...far less than ideal. Further, I never stopped zimbra and properly performed a backup; again, I thought these rsync backups of the /opt dir woudl suffice. Lesson learned.

    I have setup a new server with ZCS 8.0 Open Source and I recreated my users accounts on the new server (we'll call this new server "new8.0"). Prior to the filesystem on the old server going into a read-only state, I used imapsync to transfer 60% of the old emails from the old server (4.5.11) to the new server "new8.0".

    In addition, I have now setup another new server that mirrors the old (broken) server (we'll call this one "new4.5") . It has RHEL4.5 with ZCS 4.5.11 running.

    I have tried quite a few methods to take the old data (rsync "backups") and put it onto the "new4.5" in an attempt to stand-up a instance of my old4.5 data so I can complete the imapsync of data to the "new8.0" - nothing has worked so far.

    Can anyone provide some suggestions on how I could use a rsync'ed backup of the /opt directory to temporarily get an instance running so I can access old email?

    For info, I have attempted simple methods, such as:

    rsync -auvz --delete /optBackup /opt

    cp -af /optBackup /opt

    Both of these result in the new4.5 instance of ZCS going from a working state to a state that it will not startup due to ldap errors:

    $ zmcontrol start
    Starting ldap...Done.
    /opt/zimbra/bin/ldap: line 55: kill: (9696) - No such process
    Failed to start slapd. Attempting debug start to determine error.
    bdb(): txn_checkpoint: failed to flush the buffer cache Invalid argument
    bdb(): PANIC: fatal region error detected; run recovery
    bdb(): PANIC: fatal region error detected; run recovery
    bdb(): PANIC: fatal region error detected; run recovery
    bdb(): PANIC: fatal region error detected; run recovery
    bdb_db_close: txn_checkpoint failed: Invalid argument (22)
    backend_startup_one: bi_db_open failed! (-30978)
    bdb_db_close: alock_close failed the same time, the new4.5 works without me attempting to "overlay" the old4.5 data:

    $ zmcontrol start
    Starting ldap...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.

    ...but of course this is simply a new install with no data.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Did you run zmfixperms after the restore (you should)?

    /opt/zimbra/libexec/zmfixperms --verbose --extended
    If you still get the same error then check these threads: +"txn_checkpoint: failed to flush the buffer cache Invalid argument" - Yahoo! Search Results


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Recover data from store folders
    By mkswanson in forum Installation
    Replies: 18
    Last Post: 08-01-2012, 08:33 AM
  2. Replies: 3
    Last Post: 03-14-2011, 05:17 AM
  3. Replies: 0
    Last Post: 12-18-2010, 11:23 PM
  4. SVN tree freeze and Server Extension Methods
    By JoshuaPrismon in forum Developers
    Replies: 1
    Last Post: 04-27-2007, 12:25 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts