My server HDD failed. The server's filesystem is currently in a read-only state:

OS: RHEL4.5
ZCS: 4.5.11

I had always used rsync to take "backups" of the /opt directory. I quote backups as I used that lightly being that I have now learned this is not an ideal backup...far less than ideal. Further, I never stopped zimbra and properly performed a backup; again, I thought these rsync backups of the /opt dir woudl suffice. Lesson learned.


I have setup a new server with ZCS 8.0 Open Source and I recreated my users accounts on the new server (we'll call this new server "new8.0"). Prior to the filesystem on the old server going into a read-only state, I used imapsync to transfer 60% of the old emails from the old server (4.5.11) to the new server "new8.0".

In addition, I have now setup another new server that mirrors the old (broken) server (we'll call this one "new4.5") . It has RHEL4.5 with ZCS 4.5.11 running.

I have tried quite a few methods to take the old data (rsync "backups") and put it onto the "new4.5" in an attempt to stand-up a instance of my old4.5 data so I can complete the imapsync of data to the "new8.0" - nothing has worked so far.

Can anyone provide some suggestions on how I could use a rsync'ed backup of the /opt directory to temporarily get an instance running so I can access old email?

For info, I have attempted simple methods, such as:

rsync -auvz --delete /optBackup /opt

cp -af /optBackup /opt

Both of these result in the new4.5 instance of ZCS going from a working state to a state that it will not startup due to ldap errors:

$ zmcontrol start
Host new4.5.domain.net
Starting ldap...Done.
FAILED
/opt/zimbra/bin/ldap: line 55: kill: (9696) - No such process
Failed to start slapd. Attempting debug start to determine error.
bdb(): txn_checkpoint: failed to flush the buffer cache Invalid argument
bdb(): PANIC: fatal region error detected; run recovery
bdb(): PANIC: fatal region error detected; run recovery
bdb(): PANIC: fatal region error detected; run recovery
bdb(): PANIC: fatal region error detected; run recovery
bdb_db_close: txn_checkpoint failed: Invalid argument (22)
backend_startup_one: bi_db_open failed! (-30978)
bdb_db_close: alock_close failed


...at the same time, the new4.5 works without me attempting to "overlay" the old4.5 data:

$ zmcontrol start
Host new4.5.domain.net
Starting ldap...Done.
Starting logger...Done.
Starting mailbox...Done.
Starting antispam...Done.
Starting antivirus...Done.
Starting snmp...Done.
Starting spell...Done.
Starting mta...Done.

...but of course this is simply a new install with no data.