Results 1 to 8 of 8

Thread: How to disable POP3 throttling

  1. #1
    Join Date
    Oct 2012
    Posts
    4
    Rep Power
    3

    Default How to disable POP3 throttling

    Zimbra Open Source Edition 8.0 is installed on Ubuntu 12.04 LTS @ ESXi.

    Everything works fine, but a heavy user gets "connection interrupted by the server" error on the Outlook. The mailboxd.log shows the following entry.

    2012-10-18 10:53:37,828 WARN [Pop3Server-213] [ip=192.168.100.154;] pop - throttling POP3 connection for remote IP 192.168.100.154

    Reverse proxy is not installed, and the minimum mail polling interval is set to 1 second for this user. Seen some attributes related to the proxy, but the proxy service is not enabled.

    How can I disable the pop3/imap throttling or increase the allowance?

    Thanks in advance.
    Last edited by djpark; 10-18-2012 at 06:45 AM. Reason: zimbra-proxy is not installed (changed from enabled)

  2. #2
    Join Date
    Oct 2012
    Posts
    4
    Rep Power
    3

    Default

    Found the answer.

    It is a new feature in Zimbra 8.0. It is in the release note for 8.0 but the installer contains release note for 7.2 beta, so it was missed.

  3. #3
    Join Date
    Feb 2010
    Location
    Richmond, Virginia, United States of America
    Posts
    35
    Rep Power
    5

    Default Disabling POP3 Throttling?

    Quote Originally Posted by djpark View Post
    Found the answer.

    It is a new feature in Zimbra 8.0. It is in the release note for 8.0 but the installer contains release note for 7.2 beta, so it was missed.
    So.... what is the answer, please? I re-read the release notes and do not see how to disable this "new feature" which has wreaked havoc on some of our systems and is interrupting our workflow.
    Eriks Goodwin-Pfister, CIO
    CarePoint Medical

    "People create their own questions because they are afraid to look straight. All you have to do is look straight and see the road, and when you see it, don’t sit looking at it – walk." --Ayn Rand

  4. #4
    Join Date
    Feb 2010
    Location
    Richmond, Virginia, United States of America
    Posts
    35
    Rep Power
    5

    Default

    I assume this is the same issue... one of our auto-email printers gets this error when attempting to get emails:

    > 12:24:20 PM > Checking message(s): 210
    ALERT: > 12:24:21 PM > POP3 Major error occurs during connection, code:55
    ALERT: > 12:24:21 PM > ERROR POP3 mailer Callback: erl 320 - Socket connection was aborted by remote host.
    ALERT: > 12:24:21 PM > POP3 Major error occurs during connection, code:100
    RX Faxes > 12:24:21 PM > ----------------------
    Eriks Goodwin-Pfister, CIO
    CarePoint Medical

    "People create their own questions because they are afraid to look straight. All you have to do is look straight and see the road, and when you see it, don’t sit looking at it – walk." --Ayn Rand

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by izrunas View Post
    So.... what is the answer, please? I re-read the release notes and do not see how to disable this "new feature" which has wreaked havoc on some of our systems and is interrupting our workflow.
    See p14 of the ZCS 8 Release Notes for details of the 'throttle' settings.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Oct 2012
    Posts
    4
    Rep Power
    3

    Default Zimbra 8 POP3 throttling control

    Izrunas, I hope you got your problem solved. I am writing in case you haven't, and for the public benefit.

    Zimbra 8 introduced a new feature to throttle POP3 and IMAP4 and it can cause problem to the users who check their email very frequently. The POP3 connection can be rejected by the server and the Outlook gives "connection interrupted by the server" message. /opt/zimbra/log/mailbox.log file shows similar entries as follow.

    2012-10-18 10:53:37,828 WARN [Pop3Server-213] [ip=192.168.100.154;] pop - throttling POP3 connection for remote IP 192.168.100.154

    In Zimbra 8 Open Source Release note, it writes as below.

    zimbra_8_throttle.png

    I don't really believe the default values are the requests/second, it may be requests/minute. Some experts can verify and advise.

    The current values can be checked with the following command.

    Code:
    zmlocalconfig   | grep -i throttle
    I believe setting the value to 0 will disable, but I wanted to have basic protection against POP3 hacking attempts or DOS attack. Setting bigger limit (2,000 for example) solved the problem.

    Code:
    zmlocalconfig -e imap_throttle_acct_limit = 500
    zmlocalconfig -e imap_throttle_command_limit = 25
    zmlocalconfig -e imap_throttle_ip_limit = 500
    zmlocalconfig -e pop3_throttle_acct_limit = 2000
    zmlocalconfig -e pop3_throttle_ip_limit = 2000
    
    zmcontrol stop
    zmcontrol start
    Do not include space at the sides of '=' in the command.

  7. #7
    Join Date
    Apr 2013
    Posts
    8
    Rep Power
    2

    Default

    Quote Originally Posted by djpark View Post
    Izrunas, I hope you got your problem solved. I am writing in case you haven't, and for the public benefit.

    Zimbra 8 introduced a new feature to throttle POP3 and IMAP4 and it can cause problem to the users who check their email very frequently. The POP3 connection can be rejected by the server and the Outlook gives "connection interrupted by the server" message. /opt/zimbra/log/mailbox.log file shows similar entries as follow.

    2012-10-18 10:53:37,828 WARN [Pop3Server-213] [ip=192.168.100.154;] pop - throttling POP3 connection for remote IP 192.168.100.154

    In Zimbra 8 Open Source Release note, it writes as below.

    zimbra_8_throttle.png

    I don't really believe the default values are the requests/second, it may be requests/minute. Some experts can verify and advise.

    The current values can be checked with the following command.

    Code:
    zmlocalconfig   | grep -i throttle
    I believe setting the value to 0 will disable, but I wanted to have basic protection against POP3 hacking attempts or DOS attack. Setting bigger limit (2,000 for example) solved the problem.

    Code:
    zmlocalconfig -e imap_throttle_acct_limit = 500
    zmlocalconfig -e imap_throttle_command_limit = 25
    zmlocalconfig -e imap_throttle_ip_limit = 500
    zmlocalconfig -e pop3_throttle_acct_limit = 2000
    zmlocalconfig -e pop3_throttle_ip_limit = 2000
    
    zmcontrol stop
    zmcontrol start
    Do not include space at the sides of '=' in the command.
    Thkz,

    I will try this.

  8. #8
    Join Date
    Dec 2013
    Location
    Solymar
    Posts
    3
    Rep Power
    2

    Default

    I had the same situation and changing pop3_throttle_ip_limit and pop3_throttle_acct_limit solved the problem in my case.
    Thanks a lot!

Similar Threads

  1. 7.1.1 throttling?
    By ScottChapman in forum Administrators
    Replies: 0
    Last Post: 06-20-2011, 08:12 AM
  2. how to disable TLS on pop3 server
    By old-cow in forum Installation
    Replies: 18
    Last Post: 08-12-2010, 09:46 AM
  3. POP3 Client can't LOGIN to zimbra6 POP3 server
    By warcries in forum Installation
    Replies: 1
    Last Post: 04-29-2010, 09:28 AM
  4. [SOLVED] can't disable pop3
    By Burn in forum Administrators
    Replies: 3
    Last Post: 12-24-2009, 05:59 AM
  5. [SOLVED] can't disable pop3
    By Burn in forum Installation
    Replies: 0
    Last Post: 12-23-2009, 08:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •