Results 1 to 2 of 2

Thread: Zimbra / Exchange 2010 freebusy Interop - NullPointerException error

  1. #1
    Join Date
    Oct 2012
    Posts
    2
    Rep Power
    2

    Question Zimbra / Exchange 2010 freebusy Interop - NullPointerException error

    Hello,

    I have been facing issues with Exchange 2010 SP1 / Zimbra free busy interop. The requirement is to have split domain environment setup where few mailboxes host on exchange 2010 SP1 while the rest stay on zimbra.

    In test environment, mail routing, galsync and AD authentication working fine. The zimbra users are able to see the freebusy status of the exchange users but exchange users are not able to see zimbra users status.

    It seem zimbra users are unable to post the FB information to exchange public folder. IIS log doesn’t reveals much and zimbra mailbox logs shows the following...

    2012-10-19 23:59:09,861 ERROR [EXCHANGE2010 Free/Busy Sync Queue] [] fb - error while syncing freebusy for EXCHANGE2010
    java.lang.NullPointerException
    at com.zimbra.cs.account.ldap.LdapProvisioning.fixupA ccountName(LdapProvisioning.java:751)
    at com.zimbra.cs.account.ldap.LdapProvisioning.getAcc ountByNameInternal(LdapProvisioning.java:789)
    at com.zimbra.cs.account.ldap.LdapProvisioning.getAcc ountByName(LdapProvisioning.java:773)
    at com.zimbra.cs.account.ldap.LdapProvisioning.getAcc ountByName(LdapProvisioning.java:768)
    at com.zimbra.cs.account.ldap.LdapProvisioning.get(Ld apProvisioning.java:679)
    at com.zimbra.cs.account.ldap.LdapProvisioning.get(Ld apProvisioning.java:664)
    at com.zimbra.cs.fb.ExchangeEWSFreeBusyProvider$Basic UserResolver.getServerInfo(ExchangeEWSFreeBusyProv ider.java:180)
    at com.zimbra.cs.fb.ExchangeEWSFreeBusyProvider.getSe rverInfo(ExchangeEWSFreeBusyProvider.java:938)
    at com.zimbra.cs.fb.ExchangeEWSFreeBusyProvider.handl eMailboxChange(ExchangeEWSFreeBusyProvider.java:49 9)
    at com.zimbra.cs.fb.FreeBusyProvider$FreeBusySyncQueu e.run(FreeBusyProvider.java:263)
    at java.lang.Thread.run(Thread.java:662)

    The required mail-enabled contacts are created in AD for each zimbra users. Respective Foreign Principals are also set in zimbra.

    Exchange is using self signed certificate that has also been imported to zimbra.

    FreeBusy interop is configured globally and the configuration is as follows

    [zimbra@str1 root]$ zmprov gacf | grep zimbraFreebusyExchange
    zimbraFreebusyExchangeAuthPassword: P@ssw0rd
    zimbraFreebusyExchangeAuthScheme: basic
    zimbraFreebusyExchangeAuthUsername: Interop2010@test-mail.com
    zimbraFreebusyExchangeCachedInterval: 60d
    zimbraFreebusyExchangeCachedIntervalStart: 7d
    zimbraFreebusyExchangeServerType: ews
    zimbraFreebusyExchangeURL: https://172.16.102.130/EWS/exchange.asmx
    zimbraFreebusyExchangeUserOrg: EX:/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)

    any idea what to do to fix this issue?

    Thanks,
    GK

    Zimbra - Release 7.1.3_GA_3346.RHEL6_64_20110928134428 RHEL6_64 FOSS edition.
    Exchange - 2010 SP1

  2. #2
    Join Date
    Oct 2012
    Posts
    2
    Rep Power
    2

    Default

    Hello,

    Can someone please share experience with freebusy interop?

    I have tried almost all possible measures to fix this issue but all in vain.

    already tried following...
    Zimbra 7.1.3 64 FOSS edition + Exchange 2010 SP1
    Zimbra 7.1.3 64 FOSS edition + Exchange 2010 SP1 + SP2 upgrade
    Zimbra 7.1.3 64 FOSS edition + Exchange 2010 SP2
    VMware KB: Configuring Zimbra and Exchange 2010 for Free/Busy information interop

    Zimbra logs (trace / debug / fatal / error / info) almost useless and doesn't say much about the issue.

    I am wondering if someone ever manage to configure F/B between exchange 2010 and zimbra successfully.

    Thanks,
    GK

Similar Threads

  1. Replies: 2
    Last Post: 12-26-2012, 10:13 PM
  2. Replies: 4
    Last Post: 07-30-2012, 07:16 AM
  3. Replies: 0
    Last Post: 05-10-2012, 08:12 AM
  4. Free/busy interop with Exchange 2010?
    By goo0h in forum Administrators
    Replies: 3
    Last Post: 10-15-2010, 04:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •