Results 1 to 2 of 2

Thread: IPv6 error when upgrading from Ubuntu 8 LTS to Ubuntu 12 LTS?

  1. #1
    Join Date
    Sep 2010
    Posts
    30
    Rep Power
    5

    Default IPv6 error when upgrading from Ubuntu 8 LTS to Ubuntu 12 LTS?

    Hello everyone,

    I had a Zimbra 7.2.1 on Ubuntu 8 LTS, and wanted to upgrade to Zimbra 8 / Ubuntu 12 LTS. So I made a fresh Ubuntu installation, copied the /opt from the old server, and ran ./install.sh. This ends up with the following:

    Sun Oct 21 00:03:10 2012 Operations logged to /tmp/zmsetup.10212012-000247.log
    Sun Oct 21 00:03:10 2012 checking isEnabled zimbra-ldap
    Sun Oct 21 00:03:10 2012 zimbra-ldap is enabled
    Sun Oct 21 00:03:10 2012 Initializing ldap...
    Sun Oct 21 00:03:10 2012 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET6: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 137.

    I googled for quite a while now, and all I could find was timeout problems with IO::Socket::INET (<= no 6 here). Timeout problems may indicate DNS problems, while I see here a "connection refused", which is not a DNS issue IMO.

    zmldapinit line 137:
    my $ldap = Net::LDAP->new("$ldap_master_url") or die "$@";

    My idea now is that the perl Net::LDAP module changed it's behavior and tries to connect (also) via ipv6, while the zimbra ldap server doesn't listen on any ipv6 interface.

    Has anybody some idea how I can get this solved?
    Has anybody already done these steps zimbra7/ubuntu8 => zimbra8/ubuntu12 successfully?

    Thanks for help!
    Andre

  2. #2
    Join Date
    Jun 2010
    Posts
    6
    Rep Power
    5

    Default

    I had this same issue on a fresh install on a CentOS 6.3 box, and it ended up being that my Puppet configuration overwrote the /etc/sudoers changes that the Zimbra install adds to the file. See Sudoers - Zimbra :: Wiki for what should be in there.

    other things I've seen people suggest is ensuring your /etc/hosts file is formatted correctly and ensuring that your DNS is also correct for the server, but the sudoers is what did it for me. Another thing that I wasted time on was disabling IPv6, both in the OS and via zmlocalconfig per the instructions here: Configuring for IPv4 - Zimbra :: Wiki but that did not help either. Hope this saves you some time!

Similar Threads

  1. Upgrading to ubuntu 11.10
    By drdre in forum Administrators
    Replies: 3
    Last Post: 10-14-2011, 07:51 AM
  2. Replies: 4
    Last Post: 01-18-2011, 02:36 PM
  3. Zimbra 6 on Ubuntu 8.04 x64 reverting to IPv6
    By nimble7 in forum Installation
    Replies: 1
    Last Post: 11-30-2010, 12:03 AM
  4. Upgrading zimbra AND ubuntu
    By elesouef in forum Administrators
    Replies: 7
    Last Post: 03-27-2008, 10:07 AM
  5. Problem Upgrading to 4.5.5 on Ubuntu 6.06 LTS
    By carlo in forum Installation
    Replies: 1
    Last Post: 05-14-2007, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •