Results 1 to 2 of 2

Thread: zimbraPrefFromAddress not working

Threaded View

  1. #1
    Join Date
    Aug 2012
    Rep Power

    Default [SOLVED] zimbraPrefFromAddress not working


    We're evaluating Zimbra 8 NE. I'm trying to set up a default From address for our users. We want users to log in using the default domain so they don't have to enter a domain, so it matches everything else here w/AD authentication. Therefore, we have user@domainA for their account and a user@domainB alias for their "real" address (plus other aliases, like first.last@domainB, probably). I'm trying to set the default From address to user@domainB. For example: User "jdoe" logs in as "jdoe" everywhere and we want to preserve that. So I have for the account, and for the alias. I wasn't able to set this up any other way...

    No matter what I do, however, the zimbraPrefFromAddress doesn't work at all. I've tried setting it via CLI, as I was hoping to do from a script during the migration, but that doesn't work. I also tried from the GUI in Preferences > Accounts, but it still doesn't work. It gets set properly, and I've logged out/in and waited a while for it to "take effect", but it never does. It always uses the account address instead.

    Changing zimbraMailCanonicalAddress does change the From address, but I'm not sure that's the correct way to do this (and the user couldn't change it if they have other aliases).

    Does anyone have this working in Z8? Any ideas what I could try or check?

    Last edited by jce; 10-24-2012 at 01:20 PM. Reason: Found the problem; reply #1.

Similar Threads

  1. Set zimbraPrefFromAddress via SOAP
    By Tobo in forum Developers
    Replies: 1
    Last Post: 11-03-2011, 12:43 AM
  2. Replies: 0
    Last Post: 08-11-2011, 04:42 PM
  3. Replies: 0
    Last Post: 01-17-2011, 10:45 AM
  4. Replies: 0
    Last Post: 01-17-2011, 10:45 AM
  5. Replies: 2
    Last Post: 05-20-2010, 08:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts